JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Electrical, Audio, GPS, & 2-Way Radio (http://www.jeepforum.com/forum/f20/)
-   -   DIY: Radio removal w pics (http://www.jeepforum.com/forum/f20/diy-radio-removal-w-pics-996992/)

plac 03-22-2010 09:59 PM

DIY: Radio removal w pics
 
Will this oem radio fit my Jeep? (+full DIY radio removal w pics)

Summary:
2007 Wrangler Sahara
I have a RES radio without satellite button. I want a radio with satellite button, I must get my SIRIUS back. I have ordered an RES radio with SAT button, BUT a lot of places show 2008 and above. I am worried that I only have 1 harness instead of 2, but you will see that down in my pics later.

You start by removing the upper dash. You pry right in this crevice. It is large and you have plenty of room to pry without scratching anything. It pops up very easily like butter.

http://www.bellbottomblasters.com/im...wrangler10.jpg

http://www.bellbottomblasters.com/im...wrangler11.jpg

After popping both sides, you just pull up on the back:

http://www.bellbottomblasters.com/im...wrangler12.jpg

Then you slide it forward and it comes off. Don't pull too hard! You might have your compass harness here like I do:

http://www.bellbottomblasters.com/im...wrangler13.jpg

I did not disconnect the harness, you can just lay that piece carefully on the dash. Sometimes disconnecting things can trigger a CEL and I dont know Jeeps in that respect. VW's were very picky.

Next, you move to the lower dash cover. You pry from the top of it like this:

http://www.bellbottomblasters.com/im...wrangler14.jpg

After popping both sides, it pulls forward like this:

http://www.bellbottomblasters.com/im...wrangler15.jpg

See how it hooks into the bottom, and then the top snaps into place:

http://www.bellbottomblasters.com/im...wrangler16.jpg

You then remove the 4 bolts from your large console frame. (No pics.)

Then, you start gently pulling. I pulled from the bottom. I then found out that is a good idea because most of the clips are at the bottom. I had 2 on each side near the bottom. This part was not quite as easy as the other covers, but did come off with very careful pursuasion. Don't just pull on the bottom and snap it. You need to get your fingers behind it to help push it from behind also. After the 4 clips at the bottom are popped, I had nothing in the middle and just 2 clips near the top. Then, it was out:

http://www.bellbottomblasters.com/im...wrangler17.jpg

I was then looking at my radio, and the 4 bolts holding it in:

http://www.bellbottomblasters.com/im...wrangler18.jpg

Remove your 4 bolts, then very carefully pull your radio out. I could tell mine had never been out, as it took some effort to pop it loose. I then found the following harnesses plugged into my deck:

http://www.bellbottomblasters.com/im...wrangler19.jpg

My decks part number:

http://www.bellbottomblasters.com/im...wrangler20.jpg

The only 2 harnesses back there:

http://www.bellbottomblasters.com/im...wrangler21.jpg

I am a bit worried, as a lot of pictures of radios I have seen have 2 large harness plugged into them. I do not know if this RES SAT radio I ordered will work. I will find out tomorrow when it arrives.

YellowDuck 03-23-2010 08:15 AM

Awesome!!!
 
Very useful thread! Takes all the spookiness out of it - nothing like prying away at your dash covers for the first time when you don't know for sure how they are attached. I am book-marking this.

:2thumbsup:

plac 03-23-2010 11:56 AM

The new RES with SAT worked fine, and the SAT button works. Now I'm just waiting for my antenna kit.

plac 06-12-2010 10:33 AM

Update to add some better info:

Slide out your 2 center vents before you even start this just to have more room to work and see behind it. The vents just twist to the left a tad and then pull right out. They go back in just as easily, twist to the right once seated.

dogshrimper 07-03-2010 12:00 PM

Thanks for the info, I used this to install an RBZ MyGig in my 2010 JKU.

The MyGig works perfectly but since the install the compass has stopped working. I really hope it's loose connection under the first piece of trim that I removed, tracing this back all the way to the instrument panel will be a major PITA

dogshrimper 07-04-2010 09:29 PM

Quote:

Originally Posted by plac (Post 9139136)
I did not disconnect the harness, you can just lay that piece carefully on the dash. Sometimes disconnecting things can trigger a CEL and I dont know Jeeps in that respect. VW's were very picky.

What's a CEL?

plac 07-04-2010 09:41 PM

Quote:

Originally Posted by dogshrimper (Post 9735945)
What's a CEL?

check engine light

dogshrimper 07-04-2010 10:50 PM

Thanks.

Didn't have a CEL after changing the head unit but I just did a recalibration of the compass as per the instructions in the manual. Compass is working again now.

Vin 08-22-2010 08:36 AM

Did your radios work correctly once you put them in, or did you need to have the computer reflashed? I know if I add the Uconnect, I have to go back to the dealer to have it turned on.

dogshrimper 08-22-2010 11:56 AM

Radio worked on its own, didn't need any dealer help. Just had to recalibrate the compass as mentioned before.

First time I turned it on, it displayed the Dodge logo which had me a bit worried. Came back next morning and it was saying Jeep on power up and has done since

Vin 08-22-2010 12:26 PM

Awesome. Ordered one before figuring what the heck, if I have to go to the dealer I go to the dealer. $370 for a MyGig, um no brainer.

BoomBoom 09-01-2010 07:19 AM

Thanks for the pics, been looking at a new radio but was a bit tentative to dig into the dash...

InDurango 10-06-2010 02:53 PM

Pics no longer work... :(

plac 10-06-2010 03:41 PM

Quote:

Originally Posted by InDurango (Post 10240657)
Pics no longer work... :(

fixed

matikos98 11-08-2010 11:49 AM

no after pics?


The time now is 01:12 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.