cluster, wrangler - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > cluster, wrangler

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-17-2013, 06:45 AM   #1
bobacsjeep
Registered User
 
Join Date: Jun 2013
Location: falconer, ny
Posts: 3
cluster, wrangler

Started 2010 JKU, wipers came on, wouldn't shift out of park ! No guages!
Ok, I've seen this problem with some Liberties on here. And apparently there was a TSB out for them, but nothing on wranglers.....Not that it would've helped me since I have 38000 on mine.
My jeep has been in the shop for one week now. They claim the cluster was bad. Its supposedly on back order to boot!
If this has been an issue with jeeps shouldn't Chrysler be doing something about it????!!!!

bobacsjeep is offline   Reply With Quote
Unread 06-18-2013, 06:01 AM   #2
bobacsjeep
Registered User
 
Join Date: Jun 2013
Location: falconer, ny
Posts: 3
No comments or help on this one???!!!
Does anyone know on the similar isssue with the 08 Liberty why the cluster went bad? short,fuse,bad program....???
bobacsjeep is offline   Reply With Quote
Unread 06-20-2013, 07:24 AM   #3
bobacsjeep
Registered User
 
Join Date: Jun 2013
Location: falconer, ny
Posts: 3
9 days and counting........my 25 thousand dollar jeep sits at the chrysler shop disabled............
bobacsjeep is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.