Charging issue/Question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Charging issue/Question

Disc Brake Kits from ECGSECGS JK Dana 60 Bolt In Rear DiffGEARSHADE Pocket Tops in stock and available at ROCKRIDGE

Reply
Unread 10-17-2013, 01:42 AM   #1
tj1072
Registered User
 
Join Date: Oct 2013
Location: Chicago, IL
Posts: 3
Charging issue/Question

Hello all.

I have a 2002 Jeep Grand Cherokee Laredo. 6 Cyl/4.0. I am having a strange charging problem that I hope some one can help me with. It has a new alternator already, and the battery tested ok.

Here's what it's doing. Upon startup, the voltage gauge is fairly stable, it fluctuates slightly. As the vehicle warms up, it gets worse, and will vary between a little above 14 on the gauge, to almost down to 9 on the gauge, It does this continuoulsy back and forth, almost as if it's "Hunting". I'm questioning the PCM I guess, as well as the Battery Temp Sensor.

Also, sometimes at idle, the voltage will fall real quick, and the engine changes in sound, almost as if there was a sudden load put on the alternator. When this happens, I get a good amount of engine noise through a subwoofer I have in the vehicle.

Sorry for a long post, just trying to remember all the info I can for you. Thanks in advance.

tj1072 is offline   Reply With Quote
Unread 10-17-2013, 09:47 AM   #2
chris87xj
Jeepaholic
 
chris87xj's Avatar
1987 XJ Cherokee 
 
Join Date: Sep 2008
Location: Indianapolis
Posts: 5,777
It sounds like you might have an intermittent systems ground.
I'd look around under the hood for grounding points to disassemble and clean.
__________________
***Chris***

"You can set my jeep on fire and roll it down a hill,
But I still wouldn't trade it for a Coupe DeVille."


JeepForum.com/IndyORV@Redbird-SRA
COTY 2009

Vote for the Jurassic July Cherokee Of The Month!!!
chris87xj is online now   Reply With Quote
Unread 10-17-2013, 11:18 AM   #3
tj1072
Registered User
 
Join Date: Oct 2013
Location: Chicago, IL
Posts: 3
I cleaned up grounds from the battery and such. When it does fluctuate, it's steady. It's not like 3 seconds in between, then 10, then 5. It's slowly like back and forth. I almost question the regulator.
tj1072 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.