Charging issue/Question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Charging issue/Question

Don't forget the Jeep Forum discount, 10% off!The Original 3/8" Ruffstuff Diff Cover!Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops and

Reply
Unread 10-17-2013, 02:42 AM   #1
tj1072
Registered User
 
Join Date: Oct 2013
Location: Chicago, IL
Posts: 3
Charging issue/Question

Hello all.

I have a 2002 Jeep Grand Cherokee Laredo. 6 Cyl/4.0. I am having a strange charging problem that I hope some one can help me with. It has a new alternator already, and the battery tested ok.

Here's what it's doing. Upon startup, the voltage gauge is fairly stable, it fluctuates slightly. As the vehicle warms up, it gets worse, and will vary between a little above 14 on the gauge, to almost down to 9 on the gauge, It does this continuoulsy back and forth, almost as if it's "Hunting". I'm questioning the PCM I guess, as well as the Battery Temp Sensor.

Also, sometimes at idle, the voltage will fall real quick, and the engine changes in sound, almost as if there was a sudden load put on the alternator. When this happens, I get a good amount of engine noise through a subwoofer I have in the vehicle.

Sorry for a long post, just trying to remember all the info I can for you. Thanks in advance.

tj1072 is offline   Reply With Quote Quick reply to this message
Unread 10-17-2013, 10:47 AM   #2
chris87xj
Moderator
 
chris87xj's Avatar
1987 XJ Cherokee 
 
Join Date: Sep 2008
Location: Indianapolis
Posts: 6,497
It sounds like you might have an intermittent systems ground.
I'd look around under the hood for grounding points to disassemble and clean.
__________________
***Chris***

"You can set my jeep on fire and roll it down a hill,
But I still wouldn't trade it for a Coupe DeVille."

JeepForum.com/IndyORV@Redbird-SRA
COTY 2009
Vote here for the November Cherokee Of The Month!!!
The Thanksgiving JF Membership Giveaway is here!!
chris87xj is offline   Reply With Quote Quick reply to this message
Unread 10-17-2013, 12:18 PM   #3
tj1072
Registered User
 
Join Date: Oct 2013
Location: Chicago, IL
Posts: 3
I cleaned up grounds from the battery and such. When it does fluctuate, it's steady. It's not like 3 seconds in between, then 10, then 5. It's slowly like back and forth. I almost question the regulator.
tj1072 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.