CB Help (Cobra 29LTD)? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > CB Help (Cobra 29LTD)?

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 05-17-2013, 08:21 PM   #1
gemiller
Registered User
2008 WK 
 
Join Date: Jul 2012
Location: Pine Grove, PA
Posts: 217
CB Help (Cobra 29LTD)?

So I'm completely stumped.

Firestik II 3' antenna
Saguaro 4x (Aspen Creek Offroad) - Antenna mount
Standard antenna bracket device
Cobra 29LTD
New 18' cable.

Device doesn't appear to transmit or receive. If I am parked right next to a vehicle transmitting on the same channel all I get is static but the swr gauge does swing.

The unit will not calibrate. Nothing happens when I put it in cal, key in the mic and hold it in and adjust the swr cal knob, the gauge does nothing. Even if I key in swr mode theres no response. The only response from the gauge is when another vehicle keys in but all I get is static.

I've taken the antenna bracket apart and ground down more metal to bare (beyond what I think is reasonable) and i've gotten no where.

I've tried a different antenna, cable, and mic. I'm not sure what i'm missing.

The unit never engages the "ant" light, but the tx/rx light is green unless keyed in when it goes to red. All switches appear to function correctly, but I still get no response.

__________________
2008 WK Red Rock Crystal Pearl CRD || Lifted and stuff.
gemiller is offline   Reply With Quote Quick reply to this message
Unread 05-17-2013, 11:10 PM   #2
roadcrew
Registered User
1999 WJ 
 
Join Date: Sep 2010
Location: chicago, 60641
Posts: 947
Where did the radio come from?
roadcrew is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 06:48 AM   #3
gemiller
Registered User
2008 WK 
 
Join Date: Jul 2012
Location: Pine Grove, PA
Posts: 217
Bought it at a flying j truckstop supply store
__________________
2008 WK Red Rock Crystal Pearl CRD || Lifted and stuff.
gemiller is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 08:18 AM   #4
roadcrew
Registered User
1999 WJ 
 
Join Date: Sep 2010
Location: chicago, 60641
Posts: 947
I found that someone right next to me trying to communicate over the cb was useless. I could hear his key click and it was deffinatly getting my radio but I was getting no audio. We were too close. As soon as he turned the corner and we got more than say 100' away I could understand him again.

I would try to put that radio on someone's else's antenna that I knew worked. Most radio problems are faulty antenna installs. But you should have receive just by having anything in the antenna jack. Touch it with a screwdriver for example.

Don't transmit with out a proper antenna set up. It can and will fry the cb.

You do have the Squelch and Mic gain in the right direction right?
roadcrew is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 08:46 AM   #5
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,823
Quote:
Originally Posted by gemiller View Post
The unit will not calibrate. Nothing happens when I put it in cal, key in the mic and hold it in and adjust the swr cal knob, the gauge does nothing. Even if I key in swr mode theres no response. The only response from the gauge is when another vehicle keys in but all I get is static.

Are you sure all the buttons and knobs are correctly set as detailed in your owners manual ? The CB is not in PA Mode, correct ?

I would think that your new CB is defective if it will not either transmit or receive.

Even with no antenna plugged into the CB, it should clearly receive signals from a CB transmitting within 0 - 100 feet away. Even if the antenna is incorrectly installed, or incorreclty adjusted, the S/RF meter should swing to 4 when transmitting, and the SWR function should also swing the needle to the right.
__________________
.

Between 2009 when Obama took office, and 2013, median annual household incomes have fallen by more than $2,100.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 04:58 PM   #6
gemiller
Registered User
2008 WK 
 
Join Date: Jul 2012
Location: Pine Grove, PA
Posts: 217
I've tried also open area no vehicles or anything around me and I still got nothing.

Best I can get is some crap static with all the dials maxed out and the nb/anl switch set to off with the antenna on. But still nothing seams to be receiving. And the SWR gauge doesn't move at all.

No matter what I do when I key the mic nothing happens other than if the nb/anl switch is off the static will drop but the swr gauge does nothing. The only time I got the swr gauge to move at all is when I had another vehicle key the channel I was on but all I got was static no audio.
__________________
2008 WK Red Rock Crystal Pearl CRD || Lifted and stuff.
gemiller is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 05:10 PM   #7
roadcrew
Registered User
1999 WJ 
 
Join Date: Sep 2010
Location: chicago, 60641
Posts: 947
When you the talk in the mike and the pwr/swr/cal is in the swr or cal position the needle will move. It has to be in the pwr position to move the needle when receiving.

Some times there is no one else out on the air. Do you have a friend with a radio for checks?

Edit: cuz I had my send/receive backwards.
roadcrew is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 07:49 PM   #8
gemiller
Registered User
2008 WK 
 
Join Date: Jul 2012
Location: Pine Grove, PA
Posts: 217
According to the manual in cal mode the gauge should swing when keyed in and move with cal knob but it doesn't.
__________________
2008 WK Red Rock Crystal Pearl CRD || Lifted and stuff.
gemiller is offline   Reply With Quote Quick reply to this message
Unread 05-18-2013, 08:00 PM   #9
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,823
Quote:
Originally Posted by gemiller View Post
According to the manual in cal mode the gauge should swing when keyed in and move with cal knob ......
Yes, you should be seeing that.


Your CB is probably defective. Contact Cobra directly for warranty service or exchange it for another one at the retailer.
__________________
.

Between 2009 when Obama took office, and 2013, median annual household incomes have fallen by more than $2,100.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline   Reply With Quote Quick reply to this message
Unread 05-19-2013, 08:53 PM   #10
JPNinPA
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2011
Location: Dayton, Ohio
Posts: 2,278
Quote:
Originally Posted by gemiller View Post
According to the manual in cal mode the gauge should swing when keyed in and move with cal knob but it doesn't.
When you put it in cal mode press the PTT button ans set the output to cal by adjusting the SWR cal knob. Then switch it to SWR while still holding he PTT.

This will give yor a SWRReading. But do not rely on the radios SWR meter. They are usually good enough to get you out of the danger zone.
__________________
"Never look down on anyone unless your helping them up"- Jesse Jackson
JPNinPA is offline   Reply With Quote Quick reply to this message
Unread 05-19-2013, 09:09 PM   #11
CJATE
Registered User
 
Join Date: Feb 2007
Location: cen-tex
Posts: 456
Double check grounds. If you have a buddy with the same unit, switch them. Plug his into your rig and vice versa. That will tell you if it's radio or connection.

Then send it back.


Sent from AutoGuide.com Free App
__________________
83 CJ-8 scrambler
SOA
Locked and Twin-sticked
35's, fenders cut
4.56
bad paint
leaks just about everything
CJATE is offline   Reply With Quote Quick reply to this message
Unread 05-20-2013, 08:09 PM   #12
gemiller
Registered User
2008 WK 
 
Join Date: Jul 2012
Location: Pine Grove, PA
Posts: 217
FYI, Cobra determined its a bad radio based on over the phone troubleshooting, most likely a bad audio chip and they are replacing/repairing free of charge!
__________________
2008 WK Red Rock Crystal Pearl CRD || Lifted and stuff.
gemiller is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.