brake light problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > brake light problem

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectThanksgiving holiday sale in effect @ oconeeoffroad.comRugged Ridge 8500lb Winch w/ Steel Cable $294.99 Shipped O

Reply
Unread 11-17-2010, 10:37 PM   #1
vandep
Registered User
 
Join Date: Nov 2010
Location: honolulu, Hawaii
Posts: 2
brake light problem

I have a 2003 Grand Cherokee. 4.0L 6 Cylinder...whenever i press the brake pedal the driver side brake light turns off. The passanger brake light illuminates like it is supposed to. This only happens when the headlights are switched on. as soon as i turn the headlights off my brake lights work normal. I replaced the bulb and the socket for the brake light. I have no idea what is causing this. has anyone had this problem before?


Last edited by vandep; 11-17-2010 at 10:48 PM..
vandep is offline   Reply With Quote Quick reply to this message
Unread 11-18-2010, 08:00 PM   #2
jbacorn6
Registered User
1994 XJ Cherokee 
 
Join Date: Aug 2010
Location: Chippewa Twp, PA
Posts: 28
I'm not an expert at all, but it could be a bad ground or wires crossing each other.
jbacorn6 is offline   Reply With Quote Quick reply to this message
Unread 10-17-2012, 07:13 PM   #3
Jgosses
Registered User
2004 WJ 
 
Join Date: Jan 2012
Location: Waterford, VA
Posts: 5
I have this identical problem on my sons '04 GC - what did you do to fix it?


Quote:
Originally Posted by vandep View Post
I have a 2003 Grand Cherokee. 4.0L 6 Cylinder...whenever i press the brake pedal the driver side brake light turns off. The passanger brake light illuminates like it is supposed to. This only happens when the headlights are switched on. as soon as i turn the headlights off my brake lights work normal. I replaced the bulb and the socket for the brake light. I have no idea what is causing this. has anyone had this problem before?
Jgosses is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.