Blinkers and hazards not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 10-02-2010, 05:48 PM Thread Starter
czaplicki
Registered User
 
Join Date: Sep 2010
Location: Huntsville
Posts: 9
Blinkers and hazards not working

First I want to say thanks in advance.

I have searched this forum and it seems like no one has had the same problem as me, and if so could you please post a link to the thread.

I have a 1994 XJ 4x4 4.0L.

The blinkers and hazards do not work. I checked all the fuses under the dash and in the engine compartment. There is no clicking noise or lights in the dash indicating that the blinkers are on. I also checked all the bulbs and they seem fine.

Any help would be much appreciated!

czaplicki is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 10-02-2010, 06:42 PM
Vin
Registered User
2012 JK Wrangler 
 
Join Date: May 2010
Location: Long Island
Posts: 3,472
on the fuse panel under the dash, there should be 2 cylinder type things. These are what cause the hazzards and turn signals to blink. There are called flashers.
Vin is offline  
post #3 of 10 Old 10-02-2010, 06:56 PM Thread Starter
czaplicki
Registered User
 
Join Date: Sep 2010
Location: Huntsville
Posts: 9
Quote:
Originally Posted by Vin View Post
on the fuse panel under the dash, there should be 2 cylinder type things. These are what cause the hazzards and turn signals to blink. There are called flashers.
I will replace those tomorrow and let you know if that worked.

Thank you!
czaplicki is offline  
post #4 of 10 Old 10-02-2010, 07:55 PM
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA
Posts: 6,276
Same thing happened to my WJ. Poor build quality by whoever made the blinker. The solder must not have been heated enough at the factory because what happens is the solder joints split. If you're handy with a soldering iron you can crack the flasher open and resolder where the contact pins meet the flasher board. Its quick, easy, and freeee. Thats what I did. Alternatively you can buy a new flasher if you're not big on soldering and just pop it in

98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline  
post #5 of 10 Old 10-05-2010, 02:45 AM
chris87xj
JF Admin
 
chris87xj's Avatar
1987 XJ Cherokee 
 
Join Date: Sep 2006
Location: 3rd rock from sun
Posts: 10,268
'94 XJ fuse panel actually looks like this:


The flasher devices are the silver cylinders on the upper left and lower right. Only a couple bucks at any auto parts store.

***Chris***

"You can set my jeep on fire and roll it down a hill,
But I still wouldn't trade it for a Coupe DeVille."


JeepForum.com/IndyORV@Redbird-SRA

COTY 2009

chris87xj is online now  
post #6 of 10 Old 10-05-2010, 07:08 AM
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA
Posts: 6,276
OOPS! I was pretty tired haha, for whatever reason I thought I was still in the WJ forums

98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline  
post #7 of 10 Old 10-05-2010, 05:02 PM
chris87xj
JF Admin
 
chris87xj's Avatar
1987 XJ Cherokee 
 
Join Date: Sep 2006
Location: 3rd rock from sun
Posts: 10,268
dont ya hate switching vehicles

***Chris***

"You can set my jeep on fire and roll it down a hill,
But I still wouldn't trade it for a Coupe DeVille."


JeepForum.com/IndyORV@Redbird-SRA

COTY 2009

chris87xj is online now  
post #8 of 10 Old 10-05-2010, 05:06 PM
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA
Posts: 6,276
lol I know, right?! Haha

98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline  
post #9 of 10 Old 10-06-2010, 07:01 AM Thread Starter
czaplicki
Registered User
 
Join Date: Sep 2010
Location: Huntsville
Posts: 9
Well I got my problem fixed. It was just the hazard relay. $6.99 at autozone. It fixed both the blinkers and the hazards.

Thanks for all the help!
czaplicki is offline  
post #10 of 10 Old 10-06-2010, 07:51 AM
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA
Posts: 6,276
Quote:
Originally Posted by czaplicki View Post
Well I got my problem fixed. It was just the hazard relay. $6.99 at autozone. It fixed both the blinkers and the hazards.

Thanks for all the help!


p.s. be glad yours is so cheap, the one for the WJ is $40+ lol hence why we WJ owners figured out the repair trick

98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline  
Reply

Tags
blinkers , light , turn signal

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
First no hazards, then no blinkers, then no reverse, now no headlights? keelie Stereos, CB & Ham Radios, GPS, & Electrical. 0 09-02-2010 01:36 AM
hazards stuck on Ksellers11 Stereos, CB & Ham Radios, GPS, & Electrical. 1 12-04-2009 01:07 PM
horn, hazards and blinker stop working Darkknight66 Stereos, CB & Ham Radios, GPS, & Electrical. 1 06-30-2009 09:04 AM
Blinkers Stop Working when I go in Reverse?? Bert89yj Stereos, CB & Ham Radios, GPS, & Electrical. 3 08-12-2008 12:50 PM
Tail lights / hazards not working correctly please help! KoalaHam Stereos, CB & Ham Radios, GPS, & Electrical. 5 08-30-2007 09:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome