99 grand cherokee electrical issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > 99 grand cherokee electrical issue

Oconee Off-Road Now Offering Zone Off-Road Products!!!RIGID LED Light Blowout Sale - All Sizes, All Series, all USA Standard Chromoly Front Axle Shaft Kits with Dana 30 4

Reply
Unread 10-07-2011, 01:55 AM   #1
wj_runner99
Registered User
1999 WJ 
 
Join Date: Oct 2011
Location: Demotte, Indiana
Posts: 84
99 grand cherokee electrical issue

Sorry I hit the wrong button.

Continued from last post;

Sometimes it won't happen for a day or two but sometimes won't stop for a day or two. I can't find any bad fuses or loose/broken wires anywhere. Also it won't pass emissions because the computer can not link up with my jeep. Please help.

wj_runner99 is offline   Reply With Quote
Unread 10-07-2011, 08:45 AM   #2
tennman1990
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2011
Location: Knoxville, Tennessee
Posts: 74
I know you said you already checked for broken wires but... did you happen to check in the driver's door boot where the wires go from the chassis to the door? I say that because my '95 ZJ had a broken ground wire in there and would only work the power windows when the door was shut. I don't know too much about the new models but maybe yours has the feature like my TJ where when I open the door it shows me the mileage (digital). Possibly yours turns on the dash cluster lights instead so that you can see the mileage?
The next place I would look if all is well there is somewhere down the line of the switch on your door that activates when you open and close, although I've never encountered a vehicle before that wouldn't let you operate the lock/window switches with the door open.
__________________
From ZJ to TJ.
tennman1990 is offline   Reply With Quote
Unread 10-07-2011, 09:13 PM   #3
wj_runner99
Registered User
1999 WJ 
 
Join Date: Oct 2011
Location: Demotte, Indiana
Posts: 84
So I took all the wiring harnesses off both doors including the ones behind the door panels. They all looked good and clean no cuts. But since I did that the dash lights have stayed off and it finally passed emissions. The only problem I am having now is the passenger door will not lock and throws the security light on on my dash. I can hear ot clicking like its trying to work. Could this be a control module issue?
wj_runner99 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.