1980 CJ-7 Painless Engine Harness Confusion - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 12-19-2012, 01:09 AM Thread Starter
Registered User
1980 CJ7 
Join Date: Dec 2012
Location: Austin
Posts: 9
1980 CJ-7 Painless Engine Harness Confusion

Recently got my first Jeep, and hasn't taken long to put together a wish list of stuff I'd like to do! Since I'd like to add a lot of electrical improvements, I decided to start by adding a new alternator (the Powermaster 67295-303), which I installed without trouble.

However, my next step was to install a new wiring harness. I bought the Painless 10110 complete Jeep harness. Got the dash harness in no problem, mounted the engine bulkhead connector, and then totally panicked! The Painless manual (here's a link) gets WAY more confusing once you get into the engine harness. I've got lots of questions, but here are a few for starters (by the way, it's a 1980 CJ-7 with the inline 6):

1. I'm assuming the ignition control module is the little silver box on the fender below the engine bulkhead connector. It's got multiple wires running across the engine bay to the distributor. Do I need to cut any of these and splice the Painless harness in, or should I just keep the old wires? The old harness seemed to connect to the control module so I'm sure I'll have to splice it in somehow...

2. The manual has several different wiring diagrams, and I can't quite figure out which one I'm using. It looks a lot like the Duraspark ignition system but I can't be sure and I wonder if anyone knows what would make sense for an 80 CJ-7 with inline 6?

3. Section B of step 6 in the manual tells how to wire the ignition module group of wires. However, it completely leaves out Duraspark! There are only instructions for "Motorcraft," "Prestolite," and HEI and point style ignition systems." The manual does refer people with Motorcraft ignition module to the illustration for Duraspark, but then it goes on to tell you to wire the light blue wire #719 to the two-way connector of the ignition module. How am I supposed to do that if I've already wired #719 to the starter solenoid? Any ideas, or am I missing something?

As you might have gathered, i'm a novice with all things automotive including Jeeps, so any help is greatly appreciated!

Marca is offline  

harness , ignition , motorcraft , painless , wiring

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome