06 TJ overdrive switch not lighting up - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 08-14-2013, 01:17 AM Thread Starter
AEVBrute
Registered User
 
Join Date: Apr 2013
Location: Miami
Posts: 82
06 TJ overdrive switch not lighting up

The switch on the dash on an auto tranny has a little light in it that is supposed to illuminate while o/d is off.

Does anyone know if the switch has a bulb in it or do I replace the whole thing?

Thanks

AEVBrute is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-14-2013, 01:18 AM
jerrym_7758
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2009
Location: Carlsbad
Posts: 189
yes it has a bulb

2005 LJ Unlimited, 4.0 I6, Dana 30/44,
3" Suspension Lift, 1.25 BL, Discos, 35" MTR, Flowmaster
Exhaust, Power Door Locks With AutoPage Remote Start, XRC8 Winch,
Custom Bumpers, Front And Rear Tube Fenders, Alpine CDE-123 Head Unit,
13W1V2 JL Audio Subwoofer, A1400 JL Audio Amp
jerrym_7758 is offline  
post #3 of 5 Old 08-14-2013, 01:24 AM
jerrym_7758
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2009
Location: Carlsbad
Posts: 189
Pull switch out and bulb

2005 LJ Unlimited, 4.0 I6, Dana 30/44,
3" Suspension Lift, 1.25 BL, Discos, 35" MTR, Flowmaster
Exhaust, Power Door Locks With AutoPage Remote Start, XRC8 Winch,
Custom Bumpers, Front And Rear Tube Fenders, Alpine CDE-123 Head Unit,
13W1V2 JL Audio Subwoofer, A1400 JL Audio Amp
jerrym_7758 is offline  
post #4 of 5 Old 08-14-2013, 01:27 AM
jerrym_7758
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2009
Location: Carlsbad
Posts: 189
I believe bulb is neo3 it is an led replacement http://www.superbrightleds.com/searc...nt-bulbs/neo3/

2005 LJ Unlimited, 4.0 I6, Dana 30/44,
3" Suspension Lift, 1.25 BL, Discos, 35" MTR, Flowmaster
Exhaust, Power Door Locks With AutoPage Remote Start, XRC8 Winch,
Custom Bumpers, Front And Rear Tube Fenders, Alpine CDE-123 Head Unit,
13W1V2 JL Audio Subwoofer, A1400 JL Audio Amp
jerrym_7758 is offline  
post #5 of 5 Old 08-14-2013, 10:17 AM Thread Starter
AEVBrute
Registered User
 
Join Date: Apr 2013
Location: Miami
Posts: 82
thanks all, any pointers on how to pull the switch out. I tend to throw wrenches if things don't go smooth.
AEVBrute is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome