03 TJ Radio never turns off. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 05-30-2013, 04:00 PM Thread Starter
WYJackson
Registered User
2003 TJ Wrangler 
 
Join Date: May 2013
Location: Jackson
Posts: 3
03 TJ Radio never turns off.

My 03' TJ got a little wet. Now the radio never turns off. Any Ideas?

I pulled the radio and checked the leads on the radio harness

Radio 12v red/white
Radio Ignition pink
to
Radio Ground black

And both had 12V with the keys removed from the ignition.

I used a volt meter to check the cigarette lighter ports just to see what else had power and they had 12V w/ the keys removed from the ignition.


Last edited by WYJackson; 05-30-2013 at 09:04 PM.
WYJackson is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-31-2013, 06:42 AM
bubbadiesel250
Registered User
2006 TJ Wrangler 
 
Join Date: Oct 2012
Posts: 33
Well you could wack it really hard and call it harsh names or check out your ignition switch to see if its letting power through. Was it everything that got wet or just the radio
bubbadiesel250 is offline  
post #3 of 9 Old 05-31-2013, 06:46 AM
RIPNBST
Registered User
2004 WJ 
 
Join Date: Mar 2013
Location: Broken Arrow
Posts: 266
You could wait til it dries out and see if the problem persists.
RIPNBST is offline  
post #4 of 9 Old 05-31-2013, 07:42 AM
gily25
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2008
Location: CT
Posts: 3,262
Did you pull the connector from the radio and look for water? If aftermarket pull the connector adapter too. Do you have any other keyed accessories? Are they working without the key too?

iPhone app user; excuse typos...thanx.
gily25 is offline  
post #5 of 9 Old 05-31-2013, 12:36 PM Thread Starter
WYJackson
Registered User
2003 TJ Wrangler 
 
Join Date: May 2013
Location: Jackson
Posts: 3
It was upside down in about two feet of water so quite a bit got wet but its been drying for about a week and half now.

I don't believe it to be an issue with the radio or its adapter, I pulled everything out back to the factory harness and that is where I checked the voltage on the:
12V - Red (which I believe should always read 12V)
12V Ignition - Pink (which always reads 12V but I believe should read 0 when the car is off and keys are removed)

I just pulled apart the steering column to look at the ignition switch, however I have no idea what I am looking at, or what needs to be disassembled to test and see if the ignition switch is what is letting the power through.
WYJackson is offline  
post #6 of 9 Old 05-31-2013, 12:58 PM
bubbadiesel250
Registered User
2006 TJ Wrangler 
 
Join Date: Oct 2012
Posts: 33
Ah well that sums it up pretty easy. Get a heat gun and start drying everything out completely. I would test the ignition wiring at the plug and if its showing voltage then focus your drying on the switch working it back and forth some. It may have shorted out internally
bubbadiesel250 is offline  
post #7 of 9 Old 05-31-2013, 04:16 PM Thread Starter
WYJackson
Registered User
2003 TJ Wrangler 
 
Join Date: May 2013
Location: Jackson
Posts: 3
Pulled the plug from the ignition switch and radio remained on so the switch does not appear to be the issue. I pulled all of the relays in the fuse box under the hood and the radio remained on.
I believe it must be something between the ignition and the radio. Does anyone know where I can get a wiring diagram to trace the line from the radio backwards?
WYJackson is offline  
post #8 of 9 Old 06-04-2013, 11:11 AM
4x4fun
Registered User
2001 TJ Wrangler 
 
Join Date: Nov 2011
Location: Livonia
Posts: 20
Hayes or Chilton manual at any auto parts
4x4fun is offline  
post #9 of 9 Old 06-05-2013, 09:10 PM
gily25
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2008
Location: CT
Posts: 3,262
Id look at the speakers too bc if something is shorting out there it could cause a bad ground im assuming.

but I'm guessing that radio is finished...look on Craigslist for a used unit or you can get a basic unit at wal mart (Sony or pioneer) that will do most modern functions.

iPhone app user; excuse typos...thanx.
gily25 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome