The Wifes Jeep WJ "build" - Page 5 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > Grand Cherokee General Discussion > The Wifes Jeep WJ "build"

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail

Reply
Unread 10-20-2010, 11:36 AM   #61
SplitNail
Registered User
1999 WJ 
 
Join Date: Aug 2008
Location: Katy, TX
Posts: 4,015
Glad to hear cleaning the TB and IAC worked!! Thats always a plus!

__________________
1999 WJ 4.7L V8, 242 TC, Front Aussie Locker, 4 Inch RC X-Series lift, 17x8 w/ 4.5BS Black Rock Vipers, 285/70/R17 BFG KM2's, All AMSOIL Synthetic Fluids

SplitNail is offline   Reply With Quote
Unread 10-20-2010, 11:41 AM   #62
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371
Quote:
Originally Posted by splitnail View Post
Glad to hear cleaning the TB and IAC worked!! Thats always a plus!
I didnt completely remove the TB, I did a cleaning while it was still attached... I just spray a full bottle of cleaner in there will keeping the RPM's up. Then I removed the IAC and cleaned it up. There was alot of built up **** that I was able to clean out, so im pretty happy with the results.


I still need hood supports, both of mine are shot and wont hold the hood up... they are cheap enough, but there are other more important areas to throw money at right now. It needs new windshield wipers, and like I said before, new steering parts... but really for the price I paid, these little tweeks here and there are totally worth the work and time.
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-20-2010, 11:46 AM   #63
SplitNail
Registered User
1999 WJ 
 
Join Date: Aug 2008
Location: Katy, TX
Posts: 4,015
I agree. I paid so little for mine. I didnt care that I put almost $1000 into the first month I owned it.
__________________
1999 WJ 4.7L V8, 242 TC, Front Aussie Locker, 4 Inch RC X-Series lift, 17x8 w/ 4.5BS Black Rock Vipers, 285/70/R17 BFG KM2's, All AMSOIL Synthetic Fluids

SplitNail is offline   Reply With Quote
Unread 10-20-2010, 01:53 PM   #64
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
hit it with some seafoam, if the TB was causing idle issues, I bet it could use it.
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote
Unread 10-20-2010, 02:08 PM   #65
Ensiferum
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 181
Just reading this thread and I had to laugh a little bit, the issues that you're in a hurry to fix are the things that some of us drive around with on a daily basis and I guess have gotten used to over time (clunks, leaks, rough idle..).

My girlfriend has a WK and any problems with hers always have priority over mine..

I'll probably get around to fixing my ZJ's issues when I put my new lift on...
Ensiferum is offline   Reply With Quote
Unread 10-20-2010, 02:11 PM   #66
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371
Quote:
Originally Posted by Ensiferum View Post
Just reading this thread and I had to laugh a little bit, the issues that you're in a hurry to fix are the things that some of us drive around with on a daily basis and I guess have gotten used to over time (clunks, leaks, rough idle..).

My girlfriend has a WK and any problems with hers always have priority over mine..

I'll probably get around to fixing my ZJ's issues when I put my new lift on...
Only because its my wifes Jeep... She isnt one to pay attention to the temp gauge, tire pressure, noises, smells, etc... One of these days Ill go drive it after not being in it for a week or two and the transmission will fall to the ground. So I have to get it in perfect running condition to avoid the damn thing exploding.
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-20-2010, 02:12 PM   #67
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371
Quote:
Originally Posted by freakinheep89 View Post
hit it with some seafoam, if the TB was causing idle issues, I bet it could use it.
Ive seafoamed the brake booster and the gas tank. Took care of a good amount of exhaust grime.
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-20-2010, 02:14 PM   #68
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
Quote:
Originally Posted by AustinTJer View Post
Ive seafoamed the brake booster and the gas tank. Took care of a good amount of exhaust grime.
ok. I must have missed it.
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote
Unread 10-20-2010, 02:17 PM   #69
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371
Quote:
Originally Posted by freakinheep89 View Post
ok. I must have missed it.
Ive been updating this thread alot... mainly just to keep record of what im doing.

Its nice having a new "project", since the TJ is pretty much don,e unless I want to spend $2000 on a tummy tuck, sye, cv ds, UCA's, etc etc etc etc etc etc etc...
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-20-2010, 02:30 PM   #70
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
Quote:
Originally Posted by AustinTJer View Post
Ive been updating this thread alot... mainly just to keep record of what im doing.

Its nice having a new "project", since the TJ is pretty much don,e unless I want to spend $2000 on a tummy tuck, sye, cv ds, UCA's, etc etc etc etc etc etc etc...
Yeah i would go crazy without stuff to mod. if its not the ZJ, its the lincoln, if its not a car, its my RC's, if its not that i start playing with guns and it gets interesting.
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote
Unread 10-21-2010, 11:42 AM   #71
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371
I know I have this going in two threads, but I replaced the low beam headlights with Silverstar bulbs and aimed my headlights up just slightly. I dont have an area close to my house to allow for a completely flat headlight adjustment, so as soon as I can, ill do an accurate adjustment, but the addition of the bulbs and aiming them up slightly has DRASTICALLY improved visibility.

Ordered the Master Pro TRE's and Monroe steering stabilizer from O' Reillys today, so Sunday ill have a little project.
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-24-2010, 08:21 PM   #72
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371



Wow, didn't realize how bad the TREs were until I got them off. Took me way longer than I wanted the process to take, but with all 4 new ends and a new stabilizer, the steering has GREATLY improved.



I'm starting to get discouraged. There are little things that have me paranoid. I think I'm just being overly sensative, because it's a "new" vehicle. Still has a rough idle when first starting it up, every one in awhile, it feels like it's shifting hard, it shuts down really rough too, found a little puddle of antifreeze in the drive way the other morning, little creaks and pops every now and then... Again, probably nothing, I just hate when shot doesn't work right; especially shot I just bought.
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-24-2010, 08:49 PM   #73
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,271
rough idle on startup is normal on a 4.0 ZJ, not sure bout the WJ. My XJ idled rough on startup, I think its a 4.0 thing.


try to find where the coolant is coming from.
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote
Unread 10-25-2010, 08:15 AM   #74
AustinCJer
u mad, bro?
 
AustinCJer's Avatar
1978 CJ7 
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 2,371
Quote:
Originally Posted by freakinheep89 View Post
rough idle on startup is normal on a 4.0 ZJ, not sure bout the WJ. My XJ idled rough on startup, I think its a 4.0 thing.


try to find where the coolant is coming from.
All the issues are so minor, again, it just bugs me when **** doesnt work right.

-Find the coolant leak and fix it.
-Stop the drivers door from POPPING when opening and closing it (I tightened the hinge, but it still pops.)
-Lubricate the slip yoke shaft to stop the "bump stop" issue.

After the TRE replacement yesterday, the pitman arm was off center, but there was no way to reduce the length of the drag link setup to center the pitman arm... The wheel still turns and extends both directions just fine. Do i need to worry about it being off? Could it damage any other steering parts?


I appreciate your input TJ, youve been a big help.
__________________
-Dave

Shameless plug: www.davidisabeersnob.com

My CJ7 Build Thread
AustinCJer is offline   Reply With Quote
Unread 10-25-2010, 08:27 AM   #75
smunns
Registered User
 
Join Date: Apr 2002
Location: , Nebraska
Posts: 1,226
Quote:
Originally Posted by AustinTJer View Post
After the TRE replacement yesterday, the pitman arm was off center, but there was no way to reduce the length of the drag link setup to center the pitman arm... The wheel still turns and extends both directions just fine. Do i need to worry about it being off? Could it damage any other steering parts?
It won't damage anything, but you should be able to center it by adjusting the drag link.
smunns is offline   Reply With Quote
Reply

Tags
2003 , build up , grand cherokee , jeep
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.