UTChavok's build thread. - Page 28 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #406 of 455 Old 04-09-2013, 07:02 PM
mtnmarc
Registered User
1999 WJ 
 
Join Date: May 2009
Location: Grass Valley
Posts: 1,541
That front spring does not look happy in the last picture. Ha.

Looks good though man.


99 WJ hp44, 3 link, Eaton e locker, 14" foa coilovers in the front. 14 bolt, 4 link, grizzly locker, 12" foa coilovers in the rear. 5.38s and 37s
mtnmarc is offline  
Sponsored Links
Advertisement
 
post #407 of 455 Old 04-11-2013, 06:17 PM
squashman702
Registered User
1994 ZJ 
 
Join Date: Aug 2007
Location: Allston
Posts: 4,425
Looks great man.

Think Twice Garage
"I guess I'd just run it?"
squashman702 is offline  
post #408 of 455 Old 05-29-2013, 06:18 AM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Did some crawlin at a hill climb a buddy of mine made at his house. Crawled right up it dry. It poured down rain all night and we hit it again and no one made it. I broke a short side inner shaft on my 44 already. Have to find a J10 axle for a replacement or order a custom made chromo from dutchman for 190....

Ohh and if you have a Youtube account we would really appreciate a subscription to our club channel!



-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
 
post #409 of 455 Old 05-29-2013, 06:13 PM
CTeunuch
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2009
Location: Sudbury, MA
Posts: 1,314
Nice background music, Sage Francis is sick.

Sucks about the 44 shaft, was it a stocker? $190 isn't bad for a chromo, that's right around what the Yukon's go for. I got mine from Randy's, but went with the USA standard shafts instead of the Yukon's. When they showed up, they had Yukon tags on them with Yukon PN's, but for half the price. They're warrantied for a year too, I blew one of mine up on the second run and they sent me another one after showing them pictures of what was left of it.

Think Twice Garage
"Yeah, that might work, pass me the grinder..."
94ZJ AX15/HP44/8.8/5.13's/35'' MTZ's SOLD
99XJ 4.0/AW4/HP30/8.25 build coming soon...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CTeunuch is offline  
post #410 of 455 Old 06-03-2013, 02:57 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Nice glad to hear about the warranty. I did not know that about Yukon's shafts, but their gears are the same way. From my understanding USA standard gears are all in the same tolerances and passed all the same tests as the Yukon gears, but they are just a little bit louder. I still have to pull the broken shaft out which I will probably do tomorrow and then order mine. I have found a J10 front driver inner on Yukons website but not sure if it is the correct length, they want $120 for it but I think I have a different year axle than the shafts for.

-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #411 of 455 Old 06-08-2013, 02:17 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Was going to order the Novak cable shifter but decided to try to fab up something on my own before I dropped $180 on that. Bought two 7/16 rod ends from mcmastercarr, used a chevy t case tab which points up instead of down like the jeep tabs and then had to make a new tab for the shifter lever, lengthed that one by an inch or so and clocked it to be parallel to the ground at 2wd. It shifts great now, it went into 4 lo so easily I thought it was broken. I've never been able to just glide it into 4 lo, I have always had to yank as hard as I could on the shifter. I'd say I came out better with this costing $15 than the $180 from novak.



-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #412 of 455 Old 06-08-2013, 02:44 PM
mcannon111
Registered User
2006 TJ Wrangler 
 
Join Date: Nov 2010
Location: irmo
Posts: 1,862
Hehe McMastercarr, we order all out parts at work from them haha

no doors, no top, no problems

live in sc? join OffroadSC.com


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mcannon111 is offline  
post #413 of 455 Old 06-08-2013, 03:40 PM
PurpleZJ
Registered User
1996 ZJ 
 
Join Date: Jan 2010
Location: kansas city
Posts: 4,197
Lucky. That method won't work for me with the ax15 since its shorter in length :/

1996 ZJ- 4.0, AX-15 5SPD/NP242, RE 4.5" lift, 36x12.50x16.5 Goodyear military surplus tires, Longarms/Tri-4 link/one ton axle build/swap in progress, arb bumper, a bunch of other goodies
1995 XJ- 4.0 HO, ax-15(stolen for swap), stock
2001 GMC Sonoma-RIP...
2002 GMC Sierra 1500 ECSB-roadtrip/long haul vehicle
RIP Troy (bigbluezj94) you wont be forgotten

December 2010 GCOTM

5spd ZJ Club Member 001

Quote:
Originally Posted by bddisi View Post
Glad you are ok. If you were a cat, you would be down to 8.:D

Quote:
Originally Posted by Greengc4x4 View Post
Everything looks great, Hellen Keller! :D

Quote:
Originally Posted by rritch View Post
plastic + Fuel + Ignition = "Bubba wake up this is gonna be good" :rofl:

RIP William Anthony Kolich(DAD)
you were the best father i could have wished for. I'll always miss you
04/28/58-2/13/11
PurpleZJ is offline  
post #414 of 455 Old 06-21-2013, 04:27 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Ahh yeah thats unfortunate.. I'm glad I got it done, I have gotten really fed up with climbing underneath it to get into 4lo.

Got solid diff covers in for me and some guys in my club, got mine for the 44 and 8.8. Also got some tube inserts in to make new links for the rear lowers. Replacing the links I have now that are from a TJ Rubicon Express long arm kit with 2" .25 wall dom and Currie Johnny Joints. Got new heims for one of my uppers as well thats shot.


-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #415 of 455 Old 06-23-2013, 02:41 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Been having electrical problems, the VIC was resetting every time I started the Jeep among other things. Threw in a yellow top a buddy had laying around and its been running great. Going to get a Diehard Platinum next time they have a sale. I also got the 44 solid cover on, pulled my broken 44 shaft and measured it to order a new chromo. I replaced a heim in my trackbar that was shot and it got rid of a clunk in the front end, and I also cleaned out my rear brake pads and sanded them down and that got rid of a grinding noise I had when braking.


Also unrelated to my Jeep, but our club got some representation in this weeks episode of Dirt Every Day. We sent a shirt to Petersons and what do you know!

-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #416 of 455 Old 06-24-2013, 04:52 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Blingin front end. Painted up the solid logo and my friends fabrication company logo.


-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #417 of 455 Old 06-24-2013, 08:09 PM
mcannon111
Registered User
2006 TJ Wrangler 
 
Join Date: Nov 2010
Location: irmo
Posts: 1,862
Quote:
Originally Posted by UTChavok View Post
Been having electrical problems, the VIC was resetting every time I started the Jeep among other things. Threw in a yellow top a buddy had laying around and its been running great. Going to get a Diehard Platinum next time they have a sale. I also got the 44 solid cover on, pulled my broken 44 shaft and measured it to order a new chromo. I replaced a heim in my trackbar that was shot and it got rid of a clunk in the front end, and I also cleaned out my rear brake pads and sanded them down and that got rid of a grinding noise I had when braking.


Also unrelated to my Jeep, but our club got some representation in this weeks episode of Dirt Every Day. We sent a shirt to Petersons and what do you know!
http://www.youtube.com/watch?v=7zGu7e7zGuQ
hell yeah this is getting posted in my thread!!

no doors, no top, no problems

live in sc? join OffroadSC.com


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mcannon111 is offline  
post #418 of 455 Old 07-07-2013, 03:06 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743


Just built new links for the rear with johnny joints on both ends. Also got a dutchman chromo for the front inner shaft I broke. I've got some Nitro 300m ujoints on the way I got for a good price too. After I get the ujoints and put the shaft in Im going to start building new coil posts for the rear with bumpstops and building shock hoops.

-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #419 of 455 Old 07-08-2013, 07:31 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Got the new links in, my old RE ones are for sale if anyones interested.

-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
post #420 of 455 Old 07-09-2013, 05:46 PM Thread Starter
UTChavok
Registered User
1998 ZJ 
 
Join Date: Oct 2007
Location: Clemson, SC
Posts: 1,743
Cut up the front to start building a bumper. The passenger side being all mangled up is gonna make this a fun fab job..


-Ronnie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UTChavok is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
WJ Build Thread tsconver Grand Cherokee General Discussion 251 08-30-2016 09:12 AM
GraKee99 WJ build thread GraKee99 Grand Cherokee General Discussion 666 12-08-2014 04:24 AM
Help on how to do a build thread coolio365 ZJ Grand Cherokee Forum 11 12-09-2011 04:14 PM
WK build thread WSPJeep Grand Cherokee General Discussion 95 11-01-2010 08:17 AM
? about starting a build thread zjzach Grand Cherokee General Discussion 5 04-17-2009 06:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome