"transmission Overheat" light comes on and wont start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 05-01-2011, 01:04 PM Thread Starter
Brad2807
Registered User
 
Join Date: May 2011
Location: columbus
Posts: 1
"transmission Overheat" light comes on and wont start

My 2007 Jeep Laredo Transmission overheat light comes on (after sitting all night) and wont start. The engine doesn't try to turn over. This isn't the first time this has occurred. In the past, they jeep will start after a few hours of sitting. Any ideas how to fix to start the car? And Yes I have checked all the fluids.

Brad2807 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-08-2011, 06:14 AM
Brettp12
Registered User
 
Join Date: Aug 2011
Location: Pittsburgh
Posts: 1
Grand cherokee will not start - transmission overheat

I have the exact same problem. Intermittent. The transmission control module, battery, starter, door locking module have all been replaced. It just did it again yesterday. Will not turn over, transmission overheat coming up on in screen display, door locks not working correctly and I could not trip the alarm. had to be towed to jeep dealership. Any advice?
Brettp12 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1997 ZJ Orvis Edition V8, "wont go over 40 mph" 166154 ZJ Grand Cherokee Forum 14 10-31-2010 02:47 PM
Automatic ZJ doesnt start in "P", but starts in "N" ChiGuy82 ZJ Grand Cherokee Forum 7 09-26-2010 12:19 AM
Wont "click" into neutral, shift column light out XJ99RedNY ZJ Grand Cherokee Forum 4 12-03-2009 11:49 AM
put transmission in and got the jeep to start but when u put in gear it wont move knobby ZJ Grand Cherokee Forum 37 11-03-2008 02:09 AM
Why wont my headlight bulbs "lock"? GGGride93 ZJ Grand Cherokee Forum 7 06-28-2006 03:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome