post #1 of Old 06-13-2013, 05:32 PM Thread Starter
LaceyD
Registered User
2005 WK 
 
Join Date: Jun 2013
Location: Camano Island
Posts: 4
Tire pressure system light gone crazy!!!

I just bought a Grand Cherokee Limited 2005 from a used car lot yesterday. All was going great until I started hearing a chiming in the car and a message about my tires being low on pressure. I checked the PSI according to the door and the tires, and they seemed fine. To double check I took the car into Les Schwab and they said all the censors and and psi were fine. I then took it to the dealer and this is what they said:

"Confirmed Tire Pressure light on, found Code C1509 Right rear tire pressure module performance. Found no lin bus voltage to right rear trigger module. suspect wiring failure between sensor and skeem module."

??????

They summed it up to me that there was a break in the line somewhere and that they would have to find it and then they gave me an astronomical quote.

Is there anyway to get around this?! Cant I just disconnect the whole thing?! I can see/tell if my tires are low, I don't even need this feature. I've called a few other places and no one seems to know. Do I just pay for it? The constant chiming in my car is driving me insane!!

any advice would help, thanks!!!!

LaceyD is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome