Snobrdrkid's WJ Build Thread - Page 437 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #6541 of 6770 Old 02-28-2014, 01:07 AM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 7,847
Quote:
Originally Posted by snobrdrkid07
I am using Mobil 1 10w-30 High Mileage Full Synthetic. Blackstone Oil Analysis as shown that the oil contains 1100 PPM ZDDP. To my understanding that is a decent number. Could it be a loose rocker arm or a clogged push rod?
The 4.0 dont have rocker arms that falls out, they Are bolted in place, not same setup as the famous 4.7.
We have been experimenting with differ oils, on my friends 4.0 ZJ, it deff runs most quiet on 15W-40,,,


2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline  
Sponsored Links
Advertisement
 
post #6542 of 6770 Old 02-28-2014, 07:28 AM
ChrisHager
Custom User Title
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 8,347
Garage
That really does sound like lifter tick...

~Chris
His: 2004 WJ - OME HD 'Kolak' Lift - Build Thread
His: 1979 J-10 - 3" on 33s - Build Thread
His: 2009 Expedition
Hers: 2000 TJ
Hers: 2010 Jetta

ChrisHager's 'Grilled' Thread

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
ChrisHager is online now  
post #6543 of 6770 Old 02-28-2014, 07:33 AM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
Thomas is that a thicker or thinner oil than 10w-30?

Chris it *sounds* like it is coming from right under the valve cover. I'd guess a rocker, but a lifter could be shooting that sound right up to the top of the motor.

Big question is, what do I do from here. Run the ATF through it, clean it out? Change oil weight? Let it go, do nothing?

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
post #6544 of 6770 Old 02-28-2014, 07:45 AM
ChrisHager
Custom User Title
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 8,347
Garage


When the lifter doesn't pump up (sticks), it creates a gap somewhere between the camshaft, lifter, push rod, and rocker arm. Due to gravity, typically the gap is between the pushrod and rocker arm, which is why you can hear the ticking at the top end. Once the lifter pumps up, the slack is eliminated resulting in a quiet valve train.

Since you JUST changed your oil and slapped on the PL30001 filter, I'd ride it out and see if anything changes. When it comes time to change your oil, revisit the situation and if necessary, consider running a little ATF through.

~Chris
His: 2004 WJ - OME HD 'Kolak' Lift - Build Thread
His: 1979 J-10 - 3" on 33s - Build Thread
His: 2009 Expedition
Hers: 2000 TJ
Hers: 2010 Jetta

ChrisHager's 'Grilled' Thread

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
ChrisHager is online now  
post #6545 of 6770 Old 02-28-2014, 07:51 AM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 7,847
Agree on the valve tick in the second video

15W-40 would be thicker, tre first number refer to thickness when cold, the lower number the colder weather it will still perform at start ups, hence why Alaska ppl use 0W-???
The second number is "thickness" at operating temp, you SHOULD stay within manufacture specs for your climate, then SHOULD be ok,,,

Idk why, but the 4.0 seems picky at oil, and might call for something ells than what manufacture listed, especially when they Get older and more worn.
We tried 10W-40 Dino, 10W-30 semi syn, 15W-40 Dino, in my friends 4.0 ZJ, just because we had it around in big quantas and wanted to flush out old motor.
Deff runs smoothest and most quiet on 15w-40 and if you aint going below freezing it wouldnt hurt anything to try, but thats really up to you to deside.

Michael, oil and or flushes Are great things and MIGHT solve SOME issues, but will never Fix real mechanicly issues, look at my engine tick, i tried about EVERYTHING, parts NEEDS to be replaced.

Do seafoam, do "ATF flush", try another oil,
THEN you will know, BTW its easy to pull valve cover and have a look,,,

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline  
post #6546 of 6770 Old 02-28-2014, 09:01 AM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
Thanks Chris for the diagram, pretty neat stuff. What I don't quite understand is why the lifter would be sticking or taking a bit of time to pump up. Is a journal semi-clogged somewhere, that area gummed up with crap? I am trying to put into words what is rattling around in my head... The lifter pumps up when it has oil pressure, and without the layer of oil it sits lower on its "place". Trying to picture how a lifter sits in there and how the oil surrounds it.


Thomas,
Sounds like the 4.0 for you liked the thicker oils due to age, wearing out etc. My biggest concern is doing damage to the motor, however minor, on cold starts going to class. I'll start it up and let it sit for 30 seconds and then I'll baby it as much as I can to school. In town, 40-45 mph, keeping it under 2000 rpms until at 200*

I am assuming in my case a sticky lifter is due to a clog or grime, not a mechanical failure? I've been trying to keep up with your motor updates, was it the cam lob failing or coming loose?

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
post #6547 of 6770 Old 02-28-2014, 09:07 AM
ChrisHager
Custom User Title
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 8,347
Garage
The lifter is kind of spongy where the push rod sits. When oil pressure is applied to the lifter, the spongy feeling diminishes as the lifter pumps up. This allows for a snug valve train, even after normal engine wear. Clogged oil passages or clogged lifters can cause them to not pump up.

~Chris
His: 2004 WJ - OME HD 'Kolak' Lift - Build Thread
His: 1979 J-10 - 3" on 33s - Build Thread
His: 2009 Expedition
Hers: 2000 TJ
Hers: 2010 Jetta

ChrisHager's 'Grilled' Thread

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
ChrisHager is online now  
post #6548 of 6770 Old 02-28-2014, 09:22 AM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
From Wikipedia on "Hydraulic tappet"

Disadvantages:
"There are a number of potential problems with hydraulic lifters. Frequently, the valvetrain will rattle loudly on startup due to oil draining from the lifters when the vehicle is parked. This is not considered significant provided the noise disappears within a couple of minutes, typically it usually only lasts a second or two. A rattle that does not go away can indicate a blocked oil feed or that one or more of the lifters has collapsed due to wear and is no longer opening its valve fully. The affected lifter should be replaced in the latter situation."

Found some good pictures of the internals of a lifter. http://www.tuning.mbs.id.au/Engine/hyd_lifter.htm

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
post #6549 of 6770 Old 02-28-2014, 10:42 AM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 7,847
Quote:
Originally Posted by snobrdrkid07
Thanks Chris for the diagram, pretty neat stuff. What I don't quite understand is why the lifter would be sticking or taking a bit of time to pump up. Is a journal semi-clogged somewhere, that area gummed up with crap? I am trying to put into words what is rattling around in my head... The lifter pumps up when it has oil pressure, and without the layer of oil it sits lower on its "place". Trying to picture how a lifter sits in there and how the oil surrounds it. Thomas, Sounds like the 4.0 for you liked the thicker oils due to age, wearing out etc. My biggest concern is doing damage to the motor, however minor, on cold starts going to class. I'll start it up and let it sit for 30 seconds and then I'll baby it as much as I can to school. In town, 40-45 mph, keeping it under 2000 rpms until at 200* I am assuming in my case a sticky lifter is due to a clog or grime, not a mechanical failure? I've been trying to keep up with your motor updates, was it the cam lob failing or coming loose?
You wont do any harm when you baby drive it until hot like you do,,,
15W-40 wouldnt harm anything as long as its stays above freezing.
You could buy a cheap 10W-40 just as a flush quick change and see how it runs with 40 weight.
If not better, do a seafoam or ATF flush and try something ells.

I "suspect" my tick problem to be related to the small play i found i my camlobe, not loose, just a small play, idk if your cam is one piece or hollow like the 4,7's thought.

If not the cam is my issue, im going in for a compression test to determine valve and valveseals working,,
If no luck,,,,,
Pull oil pan and check conecting Rods, rod bearings.

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline  
post #6550 of 6770 Old 02-28-2014, 12:59 PM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
If I remember correctly, the cams for the 4.0's were milled from a solid rod? Who would have thought a cam lobe would come loose like that.

It is still getting in the teen and 20's here so I don't think I want to put in a thicker oil, yet.

What do you all think about running some Marvel Mystery Oil?

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
post #6551 of 6770 Old 03-01-2014, 09:16 AM
Cirruslydakota
Registered User
1999 WJ 
 
Join Date: Jun 2011
Location: Towson
Posts: 1,975
4.0 is solid. 4.7 was one of the first engines to have pressed on can lobes. I think I'm remembering that correctly.

Bear - 1999 Jeep Grand Cherokee Laredo
Apollo - 2008 Mazdaspeed3
Vivienne - 2015 Chrysler 200S
Cirruslydakota is offline  
post #6552 of 6770 Old 03-02-2014, 11:58 PM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
New news to me, didn't even know that was possible. Couldn't find much on google about it, maybe I was not searching the correct terms.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
post #6553 of 6770 Old 03-20-2014, 12:16 PM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
Went to Rausch Creek Offroad Park in PA last weekend and had a great time wheeling the Rubicon. Did great on the "blue" medium trails for being barely lifted and on 31's. Used the lockers only twice when it was flexed out. The 4low and 1st great crawl over everything. I'd ride around in 4th and 5th gear at times in 4low.




Ordering Under Cover Fab Extra Clearence skid and low profile transmission mount for it next week. We were getting hung up on the factory shovel of a skid plate.

To the WJ, got it inspected the other day and came out with this invoice of "recommended services"


In their defense they were not aware of any previous service in only recommended it based on the "Mileage of the Vehicle". Saying, if it hasn't been done, it needs to be. Which is an accurate statement but, damn trying to sell service.

I paid my $16 for the state inspection and was on my way. Lol

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
post #6554 of 6770 Old 03-20-2014, 12:54 PM
ChrisHager
Custom User Title
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 8,347
Garage
Quote:
Originally Posted by snobrdrkid07 View Post
How did the MT/R K's treat you on that snowy hill?

Quote:
Originally Posted by snobrdrkid07 View Post
...To the WJ, got it inspected the other day and came out with this invoice of "recommended services"...
That's a heck of a list!

~Chris
His: 2004 WJ - OME HD 'Kolak' Lift - Build Thread
His: 1979 J-10 - 3" on 33s - Build Thread
His: 2009 Expedition
Hers: 2000 TJ
Hers: 2010 Jetta

ChrisHager's 'Grilled' Thread

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
ChrisHager is online now  
post #6555 of 6770 Old 03-20-2014, 12:59 PM Thread Starter
snobrdrkid07
Mr. WJ
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,577
Would have made it up the hill without a problem, the skid plate was shoveling down in the dirt. That is why I could not make it up. I was in low, locked front/rear, and in 4th gear for some speed. Wasn't enough to overcome the shovel, the climb had decent ruts so, high centering. MT/R's have been great tires albeit a bit loud on the highway.

Took care of all of that in Jan 2013, (and then some, ha!). I should have fore mentioned that I *ONLY* wanted to get an inspection. Haha

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~ Snobrdrkid07's ~ Overland Build Thread ~ Blue WJ "Build" Thread ~ Jeep Videos ~ Fuelly ~WJ 4.0 Trans Aux Cooler Info ~



-Michael-
snobrdrkid07 is offline  
Reply

Tags
ome hd , OME lift kit , snobrdrkid , wj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
WJ Build Thread tsconver Grand Cherokee General Discussion 249 12-02-2015 07:46 AM
ZJ dd build as i go thread BlackDaddyZJ Grand Cherokee General Discussion 151 11-05-2012 03:58 PM
I guess its time for my build thread, "Build thread." Escout03 Grand Cherokee General Discussion 81 11-13-2011 12:45 PM
My Build Thread zjrick812 ZJ Grand Cherokee Forum 5 11-16-2010 08:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome