Please help! Tail lights not working on my GC Laredo!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > Grand Cherokee General Discussion > Please help! Tail lights not working on my GC Laredo!!

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits Rough Country Jeep Suspension Deals at Rockridge 4WD!Looking to re-gear?! CRAZY DEALS ON YUKON GEARS right here

Reply
Unread 02-18-2013, 11:25 PM   #1
Texas361
Registered User
 
Join Date: Feb 2013
Location: Portland, Texas
Posts: 3
Please help! Tail lights not working on my GC Laredo!!

I have a 2003 Jeep Grand Cherokee Laredo 2wd 4.0 V6

My left tail light went completely out and so I checked out the bulds and they all looked good and couldnt figure it out. So I took it in and they said my light assembly was bad so I ordered a new one and now all the lights on it work (break, reverse, and blinker) but when I hit the breaks it does not light up! My top rear break light was also out and the guy said they hadnt looked at it but they supspected the light was just burnt out. I should had made them check it. But I took it out and the bulb looks fine and so does the connector. Does anybody have any idea what could be the reason behind these two problems?? I would much appreceate it so I wont have to hurt the wallet by taking it in again. Thank you for your time!

Texas361 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.