HVAC Blower not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 06-10-2010, 03:43 PM Thread Starter
Chaseg08
Registered User
2001 XJ Cherokee 
 
Join Date: Mar 2010
Location: Denver
Posts: 40
HVAC Blower not working

My 06' Overland A/C was on for about 10seconds when it completely cut off. It doesn't work on any setting. All the fuses are good. From what I have read on other jeep HVAC blower issues it could be the resistor/relay. Any input or thoughts before I order the part? Thanks!

Chaseg08 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Commander noisy HVAC blower motor repair the_eleven WK Grand Cherokee & XK Commander Forum 2 06-12-2012 10:27 AM
4.7L '00 GCL surging and HVAC fan not working ccajun4real ZJ Grand Cherokee Forum 6 08-17-2010 07:57 AM
Manual HVAC Blower Motor windsors03cobra ZJ Grand Cherokee Forum 1 10-19-2008 12:56 PM
1995 Grand Cherokee - HVAC panel not working BHLeonard ZJ Grand Cherokee Forum 4 02-04-2008 07:27 PM
Radio/HVAC interior lights not working dshannon ZJ Grand Cherokee Forum 1 07-09-2007 08:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome