High pitch Sqeaking - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 07-23-2013, 09:44 AM Thread Starter
JackRabbit42
Registered User
1996  
 
Join Date: Jul 2013
Location: Hesperia
Posts: 1
High pitch Sqeaking

Howdy, i have a 96 GC Laredo. Major sqeaking coming from front of motor...replaced serpentine belt several times, lower pulley and tensioner pully, alternator and scuffed up water pump pulley(glazing)? Sqeaking still there! any ideas?


Last edited by JackRabbit42; 07-23-2013 at 09:47 AM. Reason: problem not listed
JackRabbit42 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-18-2013, 04:09 PM
kirkj68
Registered User
 
Join Date: Aug 2012
Posts: 3
Quote:
Originally Posted by JackRabbit42
Howdy, i have a 96 GC Laredo. Major sqeaking coming from front of motor...replaced serpentine belt several times, lower pulley and tensioner pully, alternator and scuffed up water pump pulley(glazing)? Sqeaking still there! any ideas?
Try squirting water on one pulley at a time. If the squeaking stops you have found the source of the squeak.
kirkj68 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome