Help with a starting issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > Grand Cherokee General Discussion > Help with a starting issue

Baseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft KiClayton Off Road WJ Long Arm Kits!Clayton Off Road - JK Prototype Gas Tank Skid

Reply
Unread 02-25-2013, 07:29 AM   #1
stoneyboy16
Registered User
2003 FSJ Cherokee 
 
Join Date: Feb 2013
Location: Halifax, Nova Scotia
Posts: 7
Help with a starting issue

I just purchased a 2003 Jeep Grand Cherokee Limited with a 4.7 HO engine. Occasionally when trying to start it, It turns over longer than normal before it actually starts to run. up to 4 seconds. Once it starts to run, there is no problem and it runs great. The dealer said they origionaly thought it was an issue with the after market remote start so they disconnected it. However, it continues to do it occasionally. Doesn't matter if it is cold or hot. I just went to start it after not driving it for almost 48 hours and it started easily. Some times it takes longer even when it is warm.

Any thoughts?
Thanks in advance,
James

stoneyboy16 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.