Help! 93 grand cherokee won't start! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 01-15-2014, 07:50 PM Thread Starter
zowie95francis
Registered User
 
Join Date: Jan 2014
Location: Fond du lac
Posts: 1
Help! 93 grand cherokee won't start!

I just got my 93 grand cherokee today. The last guy (a friend of mine) just put a new battery in it and when I click the key onto the on position the gauges come on, the radio, as well as the ebrake light and the check engine light. Any opinions on what I should do?

zowie95francis is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome