post #1 of Old 07-02-2015, 11:50 AM Thread Starter
fburies
Registered User
1994  
 
Join Date: Jul 2015
Location: Chicago
Posts: 1
Help!

inherited a 1994 jeep cherokee laredo. first had a problem getting the security off...fixed that. Now the problem is it won't turn over when i try to start it. It tries to turn over but it just won't connect. Battery is fine and yes...there's gas in the car...lol.SOMEONE PLEASE HELP WITH A LOGICAL ANSWER.

fburies is offline  
post #2 of Old 07-04-2015, 05:13 AM
willnats
Registered User
2001 WJ 
 
Join Date: Dec 2014
Location: Black Mountain
Posts: 23
There are lots of issues it could be that are typical for GC; fuel pump, Crank position sensor, cam position sensor, throttle body, injectors, and the list continues. I'm not an expert but there are lots of forum members that are very good at helping you, they will need a little more information.

I would suggest, if you have a check engine light, to get the code. Turn the key to the on position (3) times(not all the way to the position that causes the engine to turn over). On the third time the odometer will display any open codes.

Any other symptoms you can provide will help you get a response from some of the forum experts.
willnats is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome