electrical issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > Grand Cherokee General Discussion > electrical issues

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineNEW!! HMF 50"-52" light bar mounting brackets!! Year End Clearance Sale! Save 20%

Reply
Unread 11-04-2012, 10:26 PM   #1
gonzo_gcc
Registered User
1994 XJ Cherokee 
 
Join Date: Nov 2012
Location: Beaverton, Oregon
Posts: 2
electrical issues

hey guys

here is the thing:
i have a jeep grand cherokee limited '94 and had it cleaned at a car wash yesterday. i noticed that there was a bit water just under the dashboard on the passenger's side. i am not sure if this has anything to do with it.

when i finished cleaning inside the car i drove home from the car wash. i noticed that the dome lights and the side lights wont go out - even at driving. after i tried to figure this out - what took forever i decided to unplug the batterie to save the batterie. this morning i tried to start it and it wouldn't start. instead i got the front lights flashing and a security light turned on. after some time i got a friend to jump start the car. we could figure out to get rid of the security thing and got it running again. but the lights were still on. so we put out the fuse ... the lights are out but another thing turned on. the heater blows out hot air even tough it is not on.

so now i have two problems:
1. the dome lights are on all the time (even when driving), unless i have not unplugged the fuse
2. the heater is running even it is not on

i have tried already the rear cargo switch, i have tried all the switches of the 4 doors.

any ideas what the problem could be???

gonzo_gcc is offline   Reply With Quote Quick reply to this message
Unread 11-05-2012, 07:38 PM   #2
gonzo_gcc
Registered User
1994 XJ Cherokee 
 
Join Date: Nov 2012
Location: Beaverton, Oregon
Posts: 2
i have an update as i drove today.

the heater is no longer working ... instead the red security light turns on after i drive a minute or so.

your help would be very appreciated!!!
thanks in advance
gonzo_gcc is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.