Brakes dragging after replacement - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 09-29-2015, 05:03 PM Thread Starter
Archermahly
Registered User
 
Join Date: Dec 2013
Posts: 33
Brakes dragging after replacement

So I swapped out rotors and pads on all 4.
Now it feels like I have a little dragging going on.
I did find some stuck pins that I cleaned up. Lubed everything, and it all seemed to move smoothly.
During bed in (6-10 progressively harder cycles of 50-10mph) I noticed it took a bit more throttle to get back up to speed. Once cool, they seem better.
Is this very unusual when changing pads and rotors?
The next day seemed better but I'm still a couple MPG low compared to normal.
BTW, this is on 2004 WJ.

Archermahly is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome