AC in 2003 Laredo-only works on speed 4 -
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back > Models > Jeep Grand Cherokee & Commander Forums > Grand Cherokee General Discussion > AC in 2003 Laredo-only works on speed 4

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectJeep Wrangler Framless, Bowless, Trektops 92-95 YJ, 97-06

Unread 08-09-2012, 07:31 AM   #1
Registered User
Join Date: Aug 2012
Posts: 1
AC in 2003 Laredo-only works on speed 4

I got these couple of issues, the cooling seems very poor on idle ( like when in a traffic Light) and now the thing does not turn on at all until the fan speed is on the highest!

Any one ran into the same?

SegoEgypt is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. is not in any way associated with Jeep or the Chrysler Corp.