post #1 of Old 02-27-2015, 07:20 PM Thread Starter
zell66
Registered User
 
Join Date: Jan 2015
Location: stevens point
Posts: 5
1998 grand cherokee limited

replaced intake manifold gaskets and plenum gasket, followed instructions per Haynes manual. got everything back together but engine sounds like it is missing. never touched the distributor except to remove wires from cap. Cant figure out if a injector is not firing properly or if timing got knocked at all. any suggestions would be helpful.

zell66 is offline  
post #2 of Old 02-28-2015, 03:12 AM
kensnelling
Registered User
1998 ZJ 
 
Join Date: Nov 2012
Location: Broken Arrow
Posts: 622
First step would be to make sure you reinstalled the wires in the cap properly, and in the right order.

Ken
kensnelling is online now  
post #3 of Old 02-28-2015, 03:28 PM Thread Starter
zell66
Registered User
 
Join Date: Jan 2015
Location: stevens point
Posts: 5
according to the haynes manual yes they are installed in correct order.
zell66 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome