02 WJ Build - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > Grand Cherokee General Discussion > 02 WJ Build

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineYear End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!!

Reply
Unread 09-24-2013, 04:29 PM   #16
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Well got my diagnosis, guy says its my BCM, and I have to go to the dealer to get it fixed.

Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 09-29-2013, 12:00 AM   #17
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
ive been watching some how to videos, I am going to plastidip the whole jeep, but I need help choosing colors, I dont know if I should do all black with bright green accents (tow hooks, jeep emblems, etc) or half a bright green and black. Like this pic only green.


Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 09-29-2013, 10:00 PM   #18
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Well after some reading the BCM is supposed to be plug and play, so I tore my dash apart this morning to get to mine so I can get the part number and start my search for the right one. Its pretty dirty so ill probably clean everything up after I install before putting all the dash back together. Until then itll sit in my back seat. Now I just need to find a donor jeep to get a BCM from


Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 10-11-2013, 03:49 AM   #19
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Today was another bad day for the jeep, I started out by taking her to the car wash, same one I always go to, and the paint on the cladding decided to start coming off. Ill have to try the krylon fusion, the duplicolor trim paint sucked. Stopped and picked up some plastidip and went home to find my BCM came. So I put the new BCM in and my wipers still dont work. Not a clue what is wrong with it. I took it to a shop and they said BCM. So being annoyed I plastidipped my rims, and my grill and my fuel door. Idk why but I felt it would look good. It all came out ok except my emblems, for some reason when I was peeling it off it would stick and come off the emblems too. So I gave up and figure ill mess with it another time. So back to my issue, I think I am going to just have to take the Jeep to the dealership and have them look at it.

Now time for pictures

Prepped for plastidip,


The new BCM


Everything apart


You can see the paint missing from the cladding.


Before and after on the rims.



Trying my emblems



Painting the grill.



Finally the fuel door.
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 10-11-2013, 09:01 AM   #20
NOVAXJ
Junior Member
 
NOVAXJ's Avatar
2002 WJ 
 
Join Date: Feb 2010
Location: Chesapeake, Virginia
Posts: 66
I had a hard time trying to plasti-dip my emblems too, it took me a couple tries. It was the same problem you have, the paint kept peeling off the emblems when I would peel it, I ended up just masking the entire emblem off, putting tape in every little edge and gap. It took a lot of time but it was much easier to paint and the paint actually stayed on the emblems lol.
NOVAXJ is offline   Reply With Quote Quick reply to this message
Unread 10-12-2013, 07:07 PM   #21
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Did my jeep emblem today, and touched up the cladding since it was looking pretty bad. I got a random idea, not sure if itll work since ive never seen anyone ever mention it. Ill try it out and share once I get paid.





Edit: I also did my wiper arms as they were getting pretty bad too, forgot to take pics if them, they look so much better
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 10-18-2013, 10:58 PM   #22
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Well a few days ago I tinted the tail lights and painted my tail light guards, it was a pita installing, the guards have 3 spots for screws, 2 use the factory screws to hold in the lights, and the 3rd I had to drill a hole in the bottom of the lights. The metal was all bent and it took a while to bend them both to fit and be straight.





Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 10-20-2013, 06:36 PM   #23
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Gave her the seafoam treatment today
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 10-25-2013, 02:22 AM   #24
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Put green leds in my speedo cluster and hvac
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 10-26-2013, 11:54 PM   #25
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281


Here are the pics I said id post.
The pics dont do it justice, its much brighter and I am very pleased, you can see on the hvac that the temp control lights arent working, the bases are broken. So I have to replace them. Ill hit a junkyard and scoop them up. What bulbs are in the evic? And can you change out the window and lock button lights?
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 11-08-2013, 12:15 AM   #26
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Well got my hideaway strobes in. Took 3 hrs to install, had to splice my own wire in to make them longer from the control box. They were only like 3ft long. But you get what you pay for I guess. 6 bucks free shipping off ebay.
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 11-17-2013, 08:42 PM   #27
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Well yesterday I went to shelby Ohio, about an hr and a half away, he made some brackets out of some angle iron he had laying around. took a few hrs, and bam! My jeep has a new look. I will have to take pics tomorrow when its not rainy. I need to take pics and a video of my strobes too.
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 11-18-2013, 07:36 AM   #28
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Here are the pics from the bull bar and the video for my strobes.






Annnnd the first sticker for the zombie build.


And here is the strobe video.
https://www.youtube.com/watch?v=JAyx...e_gdata_player
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 11-22-2013, 02:07 AM   #29
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Tune up and oil change today, idles smoother.
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 08:45 PM   #30
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Well a couple updates, yesterday I was pulled over for my tail light tint. Didnt get a ticket but I had anticipated this and went ahead and ordered some much brighter LED bulbs to shine through the tint about a week ago. These came today.

Im gonna give them a shot, I also ordered a different set of LED bulbs to put in too, http://m.ebay.com/itm/310808502524?nav=SEARCH&sbk=1, waiting for them to arrive should be here in a day or two. I only ordered them because I think the design would be cool if it shows up through the tint. Whichever works best ill order the amber and reverse to replace the rest of the bulbs. Also some bad news. After work this morning I started her up and she had the dreaded check engine light on. On the way home she was running like she was stuck in 3rd or something for like 10 min, until I pulled over, put her in park, and then turned her off. When I turned her back on she ran fine but the engine lights still on. I got the code read and its a transmission code. Its a P1763; governor pressure sensor too high. So thats my next thing to figure out. =/


Edit: so it sat all day and the light was on when I came to work, went on break and now my engine lights off.
Trxgedy is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.