where is my plug for the block heater? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 01-02-2014, 02:42 PM Thread Starter
dawomcleod
Registered User
2000 TJ Wrangler 
 
Join Date: Dec 2013
Location: Garden Village
Posts: 3
where is my plug for the block heater?

i just bought a 2000 jeep tj sport a couple months ago and i cannot find the plug in for the block heater..everything is bone stock and it's barely starting in this -35C weather..i looked everywhere, and the manual says it's located beside the air cleaner housing, but there's nothing there..or i just cannot find it..it's a canadian jeep so the manual says it comes standard..anyone have a picture or explain to me where i can find it?..thanks lol..it's frustrating

dawomcleod is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-02-2014, 07:10 PM
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
2010 JK Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,926
Quote:
Originally Posted by dawomcleod View Post
i just bought a 2000 jeep tj sport a couple months ago and i cannot find the plug in for the block heater..everything is bone stock and it's barely starting in this -35C weather..i looked everywhere, and the manual says it's located beside the air cleaner housing, but there's nothing there..or i just cannot find it..it's a canadian jeep so the manual says it comes standard..anyone have a picture or explain to me where i can find it?..thanks lol..it's frustrating
The block heater itself replaced a freeze plug located under #1 exhaust manifold port on the left hand side of the engine. A cord plugs into it which you then plug into your house extension cord.

It may be missing.

OEM part number is J5752677


http://www.factorychryslerparts.com/.../J5752677.html

Do you know what was good about the good old days? I wasn't good, And I wasn't old!

Senators and Congressman should wear uniforms like NASCAR drivers so we could identify their corporate sponsors....
laybackman is offline  
post #3 of 4 Old 01-04-2014, 12:05 PM Thread Starter
dawomcleod
Registered User
2000 TJ Wrangler 
 
Join Date: Dec 2013
Location: Garden Village
Posts: 3
yah i guess it never had one installed from factory..weird..the manual says it comes standard on canadian vehicles
dawomcleod is offline  
post #4 of 4 Old 01-04-2014, 12:06 PM
Jeffro06
Registered User
 
Jeffro06's Avatar
2006 TJ Wrangler 
 
Join Date: Jun 2007
Location: Total
Posts: 9,852
My Rubi's (it's Canadian too) cord hangs in front of the radiator, to the right, as you look at the Jeep...it's not all that noticeable.
Jeffro06 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome