tranny shifting problem , changed tranny, still not shifting - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 08-22-2013, 08:28 PM Thread Starter
sspncr
Registered User
1996 FSJ Cherokee 
 
Join Date: Mar 2009
Location: frederic, wi
Posts: 1
tranny shifting problem , changed tranny, still not shifting

I just purchased a 1989 Jeep Cherokee 4.0L Auto. Was told it was a bad tranny, wouldn't shift from 1st to 2nd, untill the RPMs are at about 4200. Then it won't go to 3rd untill it's up to 73 mph.
So I changed the tranny, but it does the same thing.

Anybody have an idea what might be the problem???????????

sspncr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-22-2013, 10:32 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Tcm. Located under passenger dash. Transmission Control Module.
Test it by unplugging it, then shift it manually. If it works that way then its the tcm.

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #3 of 4 Old 08-22-2013, 10:39 PM
Holder350
Registered User
1995 XJ Cherokee 
 
Join Date: Oct 2007
Location: Whitesburg
Posts: 5,293
Also a good possibly that the tps sensor may be bad.

Sent from my phone

95' XJ Country - Stock Skids - D30/D35 Limited Slip - 3" Lift - 31x10.50R15 - 4.0 HO - AX15 - NP231

98' XJ Classic - D30/C8.25 - 4.5" RC Lift - 33x12.50R15 - 4.0 HO - AW4 - NP231
Quote:
Originally Posted by Azzy View Post
You can tell the character of a person in how they treat someone who can do nothing for them.
Holder350 is offline  
post #4 of 4 Old 08-23-2013, 07:34 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,238
Here's a pic of the TCU.

Also, click on the link in my signature and do #1 and #10 for sure.
Attached Images
 

If you own a Renix Jeep, you'll want to check this out.

An index to over 30 write-ups can be found in the link below


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep Technical Photos


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome