Tranny Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Tranny Problems

~Artec JK 1 TON SWAP~Yukon Ultimate 35 axle kit for c/clip axles with Yukon ZipThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 04-03-2013, 06:06 AM   #1
98ZJLongIsland
Registered User
 
Join Date: Sep 2012
Location: Sound Beach, New York
Posts: 2
Tranny Problems

98 ZJ limited
220xxx on the body
90xxx on swapped motor (Freshly put it in)

So, i swapped the motor with a junkyard 6.0, 90xxx miles, and it runs great but now it seems that i have cracked the flex plate -_-, so now when its under load it makes an incredibly annoying clicking noise, NOW, here's my issue, i recently put her on the road and all was good(other than the clicking) and yesterday i took her for somewhat of a lengthy ride and as it got hotter the drive gear became sluggish, and i know this is a sign of low transmission fluid and/or over heating,(also clicking became a wee bit more prevalent as the car got hotter). I didn't look at the tranny fluid right away because it was 1am when i got her home, this morning checked the fluid(cold) and no metallic color/ burning smell. Any ideas?

EDIT: and when i swapped motors i couldnt figure out how to get tranny dipstick across to the right side so i stuck it on the left, could this effect level readings? Thanks

98ZJLongIsland is offline   Reply With Quote
Unread 04-03-2013, 11:14 AM   #2
pslack86
Registered User
 
Join Date: Jan 2013
Posts: 22
Could be shift silond pack
pslack86 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.