Timing issue? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 01-25-2009, 12:24 PM Thread Starter
Squirrely
Registered User
1948 CJ2A 
 
Join Date: Mar 2008
Location: Seattle
Posts: 7
Timing issue?

I have a 48 that someone stuffed a 260 V8 into. I just replaced the points with an electronic system. The timing was way out, so I tweaked it a little untill I got the idle smooth.

There are a couple problems.
I have timing marks on the balancer, but not on the block... so I don't know what to do to properly time my engine. Suggestions?

The engine idles smooth, and when in neutral it runs great and revs perfectly. But put the rig in gear and the engine struggles to run. It sputters and seems bogged down untill the rpm gets up to 2500 then it goes like hell. It used to backfire thru the exhaust but my timing tweak seems to have fixed this. What gives with the lack of power under load?

I put a rebuilt motorcraft 2100 on with stock jets and air fuel mix 2.5 turns out. Intake manifold is from a 302, block is a 260. Replaced fuel lines and filters, new plugs, cap, wires, roter, rewired intire engine, gas is a couple months old.


Squirrely is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Ground Issue/Dash array issue CARVAL Audio, CB & Ham Radios, GPS, & Electrical 3 12-23-2009 10:49 PM
4.2 4.0 timing issue? triz250mn Engines & Drivetrain 2 04-16-2009 07:33 PM
4.0 cam crank timing issue meucci Engines & Drivetrain 0 03-03-2009 11:07 PM
weird issue with tbi timing on 304 BigDumbBear General Jeep & Off-Road Equipment 0 02-18-2009 01:21 PM
Help - calling all flywheel and bellhousing gurus for a motor swap timing issue. jwicker Engines & Drivetrain 21 02-17-2006 07:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome