Starting Trouble 1992 XJ Cherokee - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Starting Trouble 1992 XJ Cherokee

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 12-04-2013, 11:21 AM   #1
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
Starting Trouble 1992 XJ Cherokee

Just bought a 1992 Cherokee 4.0L. It has a rough time starting when it cold. Some time it cranks and cranks and will not start but other time the engine will turn over first crank. I replace the spark plugs and wires one by one to make sure that I did not mess up the firing order. I already pulled all of the new plug again to check and make sure they were alright. Plug them all back in. Jeep still runs rough and starting problem still occurs. I know its not the starter. I was thinking of replacing the whole distributor but asking for advice before buying more parts. Also after the jeep shuts of now there is a ticking sound that seems to be coming from the spark plug area. Sound lasts for a few minutes then stop. Help please!!

Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-04-2013, 11:52 AM   #2
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,962
Hi and welcome.
When you did the plugs and wires did you change the cap and rotor?
On your 92 turn the key to run not crank and back off 3 times. Leave it "on" on the third time. Have a pen and paper, the check engine light will flash. Write down how many flashes.
All codes are 2 digits so 12 will be flash pause flash flash. 55 is end of codes.
This will help see what'd going on. Get a Haines manual it has the codes in it and is very helpful on mist repairs.
Do this and get back on here tell us the codes its probably not the distributor.
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote Quick reply to this message
Unread 12-04-2013, 04:51 PM   #3
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
Replacing the cap and roter tonight didn't have time to did it the other day. Thanks I'll post what I find
Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 11:31 AM   #4
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,962
Cool keep us up
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 02:36 PM   #5
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
I'm pretty sure I got codes 11 and 12. 11 is no crank signal to computer and 12 battery disconnected. but to me these codes don't make sense. I have not had the battery disconnected and if there wasn't a crank signal to the computer then wouldn't the Jeep just not start at all. It still sometimes starts and doesn't and now stalls out at idle some time. I'm going to double check and make sure i got the right codes.
Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 03:35 PM   #6
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
Just double checked the codes. It is reading 11 and 12
Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 03:42 PM   #7
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
Never mind did my research to understand code 11 and it make sense now
Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 03:58 PM   #8
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,962
11 makes sense for the symptoms you have. Cps if you replace it get the OEM one.
12 ... the pcm will sometimes believe the battery has been disconnected if the voltage drops below 10 for 20 seconds. No biggy.
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote Quick reply to this message
Unread 12-06-2013, 08:58 AM   #9
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
Just ordered the sensor. Thanks for the help
Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-06-2013, 10:10 PM   #10
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,962
Np. Keep jeepin
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote Quick reply to this message
Unread 12-07-2013, 06:43 PM   #11
Nick_92Cherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2013
Location: Warren, RI
Posts: 10
So put the censor in and jeep doesn't stall but still runs rough. Computer still shows the same codes. No clue as to why the jeep is running rough.
Nick_92Cherokee is offline   Reply With Quote Quick reply to this message
Unread 12-07-2013, 08:49 PM   #12
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,962
Try disconnecting the battery both wires. After 10 minutes touch the wires together then reconnect. Start it and drive it a while. It'll run Like hell for a bit.
This'll reset the ecm. After a couple of hours of running and driving it should be better. If nit then check the codes again.
Where did you get the sensor?
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote Quick reply to this message
Unread 12-07-2013, 08:52 PM   #13
JbmLaredo
Registered User
 
Join Date: Feb 2013
Posts: 143
X2^^ if sensor is from auto zone throw it in the garbage
JbmLaredo is offline   Reply With Quote Quick reply to this message
Unread 12-07-2013, 08:54 PM   #14
JbmLaredo
Registered User
 
Join Date: Feb 2013
Posts: 143
Also a good ground refreshing wouldn't hurt anything
JbmLaredo is offline   Reply With Quote Quick reply to this message
Unread 12-07-2013, 08:55 PM   #15
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,962
We should've mentioned sensors from Napa and pep boys are your best bet.
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.