Starting Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Starting Problems

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueBlack Friday SALE! Up to 20% off at Diode Dynamics!

Reply
Unread 08-26-2012, 09:12 PM   #1
carpo3
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2012
Location: Lawrenceburg, KY
Posts: 3
Starting Problems

When I go out to start my jeep. I have to crank it several times before I get it started. I need some knowledge from the jeep world on a fix for this problem.

Thanks and Go Titans!

carpo3 is offline   Reply With Quote Quick reply to this message
Unread 08-27-2012, 10:30 PM   #2
monster78
Registered User
2000 TJ Wrangler 
 
Join Date: Aug 2009
Location: Chipley, FL
Posts: 4
What year model and engine do you have? I have a 2000 4.0 and have trouble with starting. It turns over fine but I may have to turn the key off and on a few times to start.
monster78 is offline   Reply With Quote Quick reply to this message
Unread 08-28-2012, 09:01 AM   #3
Mishimoto
Registered User
 
Join Date: Apr 2012
Location: Wilmington, Delaware
Posts: 409
Welcome to JeepForum!

Do you have the problem when the Jeep is hot or cold? How many miles do you have on it, and do you have any codes? When was the last time you had a full tune-up?
Mishimoto is offline   Reply With Quote Quick reply to this message
Unread 08-28-2012, 09:12 AM   #4
thunderdan2000
Registered User
1994 YJ Wrangler 
 
Join Date: Jan 2011
Location: Flint, mi
Posts: 473
Turn the key on for 3 secs, turn it off. Do that 3 times to let the fuel pump prime the line. If it fires right up you might have a bad check valve in the tank. I have the same issue but an to lazy to drop the tank just to fix it.
thunderdan2000 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 10:14 AM   #5
carpo3
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2012
Location: Lawrenceburg, KY
Posts: 3
I have a 98 cherokee 4.0 sport with close to 200k miles on it. I have changed plugs, wires, the coil, the cap and the rotor. I have tried the turning the key and priming the pump. It doesn't help. One thing I have noticed is if it sits for 2 or 3 days it will fire right up, but a ride to the store and back you have to crank it 2 or 3 good times. and when it lights off you can smell fuel. So idk if it is not sparking or not got the fuel pressure. idk. could it be a starter? fuel pump? any ideas?
carpo3 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.