Sputter and dragging - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Sputter and dragging

OPTIC ARMOR WINDOWS all sale now !!!!!!!!Spartan Locker Special Forum Prices Dana 30 44 60 Ford 8.850" LED Light Bar with Overhead Mounting Brackets $69

Reply
Unread 08-21-2012, 05:02 PM   #1
keggles
Registered User
2006 WK 
 
Join Date: Nov 2011
Location: Riverview, FL
Posts: 62
Sputter and dragging

06 WK 4.7 I replaced the plugs with the regular champions and added a K&N. I have still been getting some weird chug a lug motions and weird pick up. Fuel filter/pump/etc?

Thanks in advance!

keggles is offline   Reply With Quote
Unread 08-28-2012, 09:31 AM   #2
keggles
Registered User
2006 WK 
 
Join Date: Nov 2011
Location: Riverview, FL
Posts: 62
Anyone have any ideas?

Transmission, fuel filter/fuel pump, just seems weird
keggles is offline   Reply With Quote
Unread 08-28-2012, 08:28 PM   #3
baldfatdad
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 582
Did you pull the codes? Automatic? Check fluid level. More info will be helpful. When does it chug? Hot, cold, speed, gear its in?
baldfatdad is offline   Reply With Quote
Unread 08-28-2012, 08:42 PM   #4
keggles
Registered User
2006 WK 
 
Join Date: Nov 2011
Location: Riverview, FL
Posts: 62
Havent pulled codes .. nothing has shown up on the dash. Its auto and doesnt have a set temp on the engine that it does it. I notice it more often around second/third.
keggles is offline   Reply With Quote
Unread 08-29-2012, 11:03 AM   #5
keggles
Registered User
2006 WK 
 
Join Date: Nov 2011
Location: Riverview, FL
Posts: 62
2006 WK 4x2 4.7 Limited
keggles is offline   Reply With Quote
Unread 09-03-2012, 02:03 PM   #6
keggles
Registered User
2006 WK 
 
Join Date: Nov 2011
Location: Riverview, FL
Posts: 62
Ttt
keggles is offline   Reply With Quote
Unread 11-15-2012, 08:17 AM   #7
keggles
Registered User
2006 WK 
 
Join Date: Nov 2011
Location: Riverview, FL
Posts: 62
Not sure if anyone else reads this, but I wanted to update.

For this issue I have been doing the following:

Changed plugs (Stock Champions)
Run Lucas Fuel Treatment
K&N Filter
Clean Throttle Body
Clean both TPS and lower sensor with TB cleaner

The TPS sensor and lower air control cleaning made the biggest difference for the chug a lug issue. I figure the remaining issues are build up on the fuel pump/filter, but its very faint what is still there.
keggles is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.