post #1 of Old 02-06-2014, 05:41 AM Thread Starter
camnelson
Registered User
1992 YJ Wrangler 
 
Join Date: Feb 2014
Location: Mesa
Posts: 1
Slow acceleration, no more that 2000 RPMS -1992 Wrangler 4.0 I6

Good morning!

I've been trying to troubleshoot my most recent Jeep acceleration etc. issue.

The Problem: Accelerates super slow, will barely push 2000 RPMs while in gear and but in Neutral will rev up just fine; Will not go over 40 MPH.

So Far: I've removed the exhuast/ CAT / O2 sensor that provided a little boost in acceleration in 1st and 2nd, but 3rd - 5th are still dead. I replaced the fuel filter & pump last year, and fuel delivery doesn't seem to be the issue.

Any suggestions?? This is (not) driving me crazy!! any help would be much appreciated, thank you !

camnelson is offline  
post #2 of Old 02-07-2014, 03:22 PM
Red Rubicon
Registered User
2003 TJ Wrangler 
 
Join Date: Jun 2002
Location: Mt. Shasta, Ca
Posts: 204
If I understand your post correctly you have checked the exhaust and converter for obstructions. Have you checked the intake? I have found everything from shop towels to rats nests plugging up air intakes.
Red Rubicon is offline  
Reply

Tags
6 cylinder , acceleration , air flow , engine , wrangler


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome