Rough idle - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 11-27-2013, 06:46 AM Thread Starter
Jtpeej
Registered User
2000 XJ Cherokee 
 
Join Date: Feb 2013
Location: Patchogue
Posts: 6
Rough idle

Just picked up a 2000 Cherokee 6 cyl. Truck runs great off the line and at speed. Problem is a rough idle. Watch the tach go from about 500 to 900. Seems worse when warmed up. When cold seems to maintain around 750rpm. Did a set of plugs and 2 tanks with a fuel additive. Noticed a crack on one of the fuel injectors. Would this matter? Any ideas?

Jtpeej is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-27-2013, 11:35 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
The crack might matter. Check engine light? Try pulling codes. It could be as simple as cleaning the throttle body. Check vacuum lines make sure they're not broke or cracked.

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome