Random "transmission over temp" message - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Random "transmission over temp" message

JK Front Lower Adjustable Control Arms!QTP Low Profile Cutouts Now @ MarylandSpeed- Free ShippingOPTIC ARMOR WINDOWS all sale now !!!!!!!!

Reply
Unread 07-31-2013, 02:55 PM   #1
mfakih
Registered User
 
Join Date: May 2013
Posts: 8
Random "transmission over temp" message

Hey all. Been noticing a weird message that appears on my dash every once in a while. I have an 05 jeep grand 4x4 standard. About 133,000km on it. Very good condition overall. I noticed sometimes i see that message "transmission over temp" it appears for a split second if not less. I seen it a few times before but never thought much of it. I figured its just the way the jeep starts considering every single dash light comes on momentarily then Goes away after the jeep starts,Which is normal in all vehicles). You have to really focus on the dash in order to catch what it actually says. It took me a few days to make out the entire message. Any ideas on whats going on? Fluid levels are good and clean. No leaks anywhere as well. The message will not reappear when the jeep is running. It only shows up for that split second when the key is turned before the ignition is kicked into power.

mfakih is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.