Please help - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 09-26-2017, 12:34 PM Thread Starter
JennyJenn
Registered User
 
Join Date: Sep 2017
Posts: 5
Please help

Hello. I'm new to this forum so I'm not sure if this is the right place to post my problems. Well, here we go: My 2006 Jeep Commander v8 4.7 L been having issues with starting up, it will act like it wants to start the first few tries until finally it starts. The jeep does run sluggish as well, it will not go over 2500 rpms and the check engine light is on. Thing's I've done according to advice from dealership and local mecahnics have been: replaced camshaft position sensor, replaced crankshaft position sensor, replaced sparkplugs and got a new battery only because it needed one. Oh let's not forget the replacement of a pcm. The dealership suggested it was either pcm or timing chain so i went with the pcm, but 3 days later after pcm was replaced the check engine light came back on. The codes p0344 and p0340 kept popping back up everytime! We took it back to dealership and now its the codes p0016 crankshaft/camshaft timing misalignment-bank 1 sensor 1 and code p0344 camshaft postion sensor intermittent- bank 1 sensor 1. We even checked the fuel pressure too. I keep getting mixed answers of what it could be. Some say yes it is the timing chain and some say its not because I would hear clanking and it would not start. Some forums say it could run with a skipped tooth or two? Idk. Any help as to what direction to go would be greatly appreciated! -JennyJenn

JennyJenn is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-26-2017, 02:09 PM
mukluk
Registered User
2000 TJ Wrangler 
 
Join Date: Oct 2010
Location: Clyde
Posts: 2,580
The code P0016 likely just needs the oil pump drive assembly (OPDA) turned just a tad to get the cam sensor back into sync with the crank sensor, the other codes may be caused by the cam sensor misalignment.

You'll probably get more of a response if you post your issue in the section of this forum dedicated to your Commander, it's located here: http://www.jeepforum.com/forum/f67/

2000 TJ SE
2005 LJ Rubicon
mukluk is offline  
post #3 of 3 Old 09-27-2017, 12:03 PM Thread Starter
JennyJenn
Registered User
 
Join Date: Sep 2017
Posts: 5
Thank u
JennyJenn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome