OM642 engine help - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 07-15-2013, 09:51 AM Thread Starter
civvy
Registered User
 
Join Date: Jul 2013
Location: cheltenham
Posts: 1
OM642 engine help

Hi, i'm having a headache diagnosing a fault with this engine and wonder if there could be some kind suggestions here..?

The engine is throwing one code: PO473.

I've tried an O2 & Backpressure sensor, but am stumped. The car smokes like a trooper, feels like it has no turbo. Flat between 2-3k (rpm) and pulls better after 3k (rpm).

thanks in advance.

civvy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome