old cj 258 running rough - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 04-02-2008, 12:14 PM Thread Starter
sparctacus
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2007
Location: Seattle
Posts: 93
old cj 258 running rough

My CJ started running extremely rough the other day. I drove it work jsut fine. But going home it wouldn't idle, and would die if I slowed down for the corners or came to a stop sign.

I've checked distributor cap + rotor, wires, and plugs, all which I just installed in December and show no signs of wear at all. I've taken the fuel filter out and run without it to test that, I've run seafoam through the tanks + carb.

I've adjusted the fast idle screw to keep it sort of running while driving it around, but am kind of at a loss as to my next (hopefully cheap) step.

The only thing I've found wrong is that it's about 1/2 quart overfull on oil.

sparctacus is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-05-2008, 11:45 PM Thread Starter
sparctacus
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2007
Location: Seattle
Posts: 93
I *think* I've narrowed this down to the cam position sensor a trip to the junkyard yeilded no results. Anyone got a distributor left over from an electronic upgrade?
sparctacus is offline  
post #3 of 5 Old 02-19-2010, 01:04 PM Thread Starter
sparctacus
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2007
Location: Seattle
Posts: 93
an update for the archives. This turned out to be a worn lobe on the cam.
sparctacus is offline  
post #4 of 5 Old 02-19-2010, 01:21 PM
JOExFROMxNY
Registered User
1988 YJ Wrangler 
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 744
Quote:
Originally Posted by sparctacus View Post
an update for the archives. This turned out to be a worn lobe on the cam.
did you change out the motor?
JOExFROMxNY is offline  
post #5 of 5 Old 02-19-2010, 02:25 PM Thread Starter
sparctacus
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2007
Location: Seattle
Posts: 93
No, just the cam.
sparctacus is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Bloody Forhead ('94 ZJ 5.2L running rough) ScottN3N Engines & Drivetrain 4 05-19-2012 07:36 AM
85 XJ 2.5 tbi running rough need ideas. TwistedEvo8 Engines & Drivetrain 0 02-18-2009 02:43 PM
AMC 258 4.2L Straight 6 on 73 Commando Running Rough 73CommandoKEYWE Engines & Drivetrain 1 09-22-2008 04:23 PM
Running Rough / Popping noise dunvillekid Engines & Drivetrain 0 06-08-2007 01:25 AM
87 2.5 running rough 79cherokee Engines & Drivetrain 1 07-16-2006 09:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome