post #1 of Old 07-03-2012, 08:17 PM Thread Starter
cc8411
Registered User
 
Join Date: Oct 2010
Location: Sikeston
Posts: 50
Oil Leak/Low Pressure At Startup/Low at Idle/Pics

Hi All,
I'm on my third Jeep. I love them but I buy and sell. This one I love. I have it set up great I think. I do have issues and maybe it is only in my mind. At startup my 2001 Sahara 120k miles shows low pressure and the check gauges light comes on and screams until the pressure goes up just after startup. I also see the pressure go down at idle. No warnings though. I also have a small leak. I would say 5 drops a night maybe. It looks like it Is from the oil pan. I also had a small leak out of the transfer case when I put it in 4x4 a few times. It seems to have gone away. I'll attach pics.
Please leg me know what you think. I could be worried over nothing. Oh, I also get a hint of burned or hit oil in my garage when it is closed off after driving the Jeep and it sets.

image-1690621015.jpg



image-248897216.jpg



image-451545293.jpg



Click image for larger version

Name:	image-451545293.jpg
Views:	71
Size:	37.1 KB
ID:	426733



image-1680081478.jpg

cc8411 is offline  
post #2 of Old 07-03-2012, 08:19 PM Thread Starter
cc8411
Registered User
 
Join Date: Oct 2010
Location: Sikeston
Posts: 50
Oh running 33" BFG KM2
cc8411 is offline  
post #3 of Old 07-05-2012, 01:58 PM Thread Starter
cc8411
Registered User
 
Join Date: Oct 2010
Location: Sikeston
Posts: 50
Talked to my uncle in law. He builds cars privately. Says no worries
cc8411 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome