O2 sensor...maybe - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > O2 sensor...maybe

RIGID LED Light Blowout Sale - All Sizes, All Series, all Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineJeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 07-25-2005, 12:26 PM   #1
tcpatter
Registered User
 
Join Date: May 2005
Posts: 47
O2 sensor...maybe

Here's the problem with the TJ. When it starts up (and is cold) it has a hard time holding decent RPMs. It will usually drop really low and if it doesn't stall, it sounds like it wants to really really bad. So far the exhaust manifold, CPS, and VCC (I think) has all been replaced and still no go. Today I'm gonna be checking the O2 sensors and maybe the TPS. Any other suggestions?

tcpatter is offline   Reply With Quote Quick reply to this message
Unread 07-26-2005, 01:22 AM   #2
TXjeepTJ
Registered User
 
Join Date: Nov 2003
Location: Magnolia and Lubbock TX
Posts: 1,024
iiii dont think 02 sensor would be causing that problem.. does it constantley have a hard time holding a decent rpm? you might want to check the throttle position sensor it might have water damage to it.. 02 sensor would send such a signla to the computer telling it to do a weird idle lol
__________________
LS1 powered TJ
http://www.jeepforum.com/forum/f7/my-v8-swap-blog-updates-365293/
C6 Z06 Corvette
TXjeepTJ is offline   Reply With Quote Quick reply to this message
Unread 07-26-2005, 07:27 AM   #3
tcpatter
Registered User
 
Join Date: May 2005
Posts: 47
Well I disconnected the O2 sensor and it didn't help. So I'm wondering about the TPS. It does almost always have a hard time holding the RPMs, but mainly when it is still cold
tcpatter is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.