No engine power, off & on acceleration, stalls out - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > No engine power, off & on acceleration, stalls out

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 10-28-2008, 06:19 AM   #1
richbrooks11
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2008
Location: Nantucket
Posts: 6
No engine power, off & on acceleration, stalls out

I have a 97 Jeep Wrangler with the 4cyl engine. It had been running mint and then last week it started acting a little "weird". Its tough to explain but it almost seems like it doesn't have the full power. I step on the gas and it has some acceleration and then none, and it does it in 1st-3rd gear because i can't get going enough to get it into 4 or 5.Also if i don't stay on the gas it dies? The check engine light has come on, but isn't flashing. I would greatly appreciate an advice from anyone. Thanks

richbrooks11 is offline   Reply With Quote
Unread 10-29-2008, 01:05 AM   #2
RIoffroad
Registered User
2002 TJ Wrangler 
 
Join Date: Oct 2008
Location: Rhode Island
Posts: 7
you could have a vacuum leak or th fuel injectors could be clogged up. next time you fill the tank buy a bottle of fuel injecter cleaner, put it in the tank after you fill up and see if that makes a difference. and look under the hood for a hose that might be cracked. i would also check to see if you have goo compression in all the cylinders.

hope this helps some
RIoffroad is offline   Reply With Quote
Unread 10-29-2008, 01:07 AM   #3
famous1688
Registered User
1989 XJ Cherokee 
 
Join Date: Jul 2008
Location: california
Posts: 105
sea-foam it and call it good...
__________________
4.5in RE superflex lift, 32's, custom bumpers under construction...
famous1688 is offline   Reply With Quote
Unread 10-29-2008, 05:55 AM   #4
MIPLAYSTATION
Registered User
2006 WK 
 
Join Date: Jul 2008
Location: Seymour TN
Posts: 7
Catalytic is fowled!!!

my 2003 Chevy Impala had the same symptoms and the catalytic was the culprit!!!
MIPLAYSTATION is offline   Reply With Quote
Unread 10-29-2008, 10:24 PM   #5
sootyjeep
Registered User
2006 KJ Liberty 
 
Join Date: Oct 2008
Location: Illinois
Posts: 53
check fuel pressure under all conditions and exhaust backpressure
Fuel 45psi
Exh less than 5psi
__________________
The only replacement for displacement is Positive Manifold Pressure.
sootyjeep is offline   Reply With Quote
Unread 10-31-2008, 05:15 PM   #6
BigTDog
Registered User
1985 CJ7 
 
Join Date: Oct 2008
Location: Interlochen
Posts: 108
Fuel filter?
BigTDog is offline   Reply With Quote
Unread 10-31-2008, 08:09 PM   #7
willness33
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2008
Location: Charlotte,NC
Posts: 365
Quote:
Originally Posted by MIPLAYSTATION View Post
Catalytic is fowled!!!

my 2003 Chevy Impala had the same symptoms and the catalytic was the culprit!!!
I'm gonna vote for a plugged cat as well.
willness33 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.