Need some 42re help. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Need some 42re help.

The Original 3/8" Ruffstuff Diff Cover!Safety Thimble FairleadsEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 11-20-2013, 05:05 PM   #1
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
Need some 42re help.

Here we go.
Picked up this 99 wj 4.0 4wd np231 last week.
Test drove it and all was fine.
Drove it 30 miles home..perfect (up over a large mountain and down) drove it to work for 2 days then the fun began.

Stop and go traffic one day on my way home..the jeep feels like its taking off in 2nd gear (less power)
after it shifted it felt just fine. Check engine light decided to come on revealing a p1757 (iirc) pointing to the governor shift solenoid.

Did some troubleshooting...
Id I put it on first..it would Actually start in first..And i could shift into 2nd or d with no problems.
Issue also seemed intermittent..happened only on ocadsion with no pattern or any particular triggers.
The check engine light would disappear randomly also.

Went ahead and bought genuine Mopar replacement governor sensor And the solenoid.

Tackled that job last night..the old fluid smelled just fine..but was somewhat nasty. Almost a brown color..and seemingly "sludgy".

Pulled the magnet in the pan, cleaned everything up..and replaced the sensor, solenoid, filter, and fluid.

I used a bit over 4 quarts of mopar atf4.
So now the trans seems to take off in 1st just fine.
However halfway home today pulling off from a red light the transmission felt like it was confused on what gear it wanted to be in..I may just be paranoid and could have just been in between gears..felt like it was going rapidly back and forth between 1st and 2nd.

Only happened one time..and was perfect the rest of the time.

Am I over thinking this?

Thoughts?

DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 06:22 AM   #2
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
No one?
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 06:49 AM   #3
vadslram
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2006
Location: VA Beach
Posts: 4,808
If you only changed out 4 qts then you still had a lot of sludgy stuff still floating around.
If the fluid wasn't nice and clear red then even if it didn't smell burnt it was degraded. Or the PO put some snake oil in there to make it run nice for the sale.
I didn't see how many miles were on the tranny. But the RE is self adjusting right up to where it can't anymore.

I would say take it to an Amoco, at least around here they do free diagnosis and can tell you what if anything is wrong and what they would charge to fix it. That way you have some starting point to do the work yourself.
vadslram is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 06:52 AM   #4
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
I dont think its anything internal to the trans anymore though.
Its SO intermittent its ridiculous, happens very randomly, and seldomly.

Almost starting to consider the TPS
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-22-2013, 08:24 AM   #5
vadslram
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2006
Location: VA Beach
Posts: 4,808
TPS might be the issue if the engine ran like crap too.
My truck has the 47RE and got a crash course in them this year.
The majority of shift determination in the RE is internal sensors and solenoids or by the TCM.
Clogged passages or sticky/leaking solenoids will delay shifts and make the engagement intermittant. The TCM controls shift points and TC lock up. So strongly in fact that if you have two wires shorting between the TCM and the tranny the TC will lock up at 0 miles an hour and stall the vehicle if you stop (guess how I know that)
The shift bands are self adjusting but give no indication they have run out of adjustment until one day they just don't shift at all, no slipping, just no shifting (that happened last year).

If it is that intermittent check all the connections and wiring between the computer and the transmission. Electrical gremlins are the most annoying.
vadslram is offline   Reply With Quote Quick reply to this message
Unread 11-25-2013, 07:10 AM   #6
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
So, replaced the governor pressure sensor, and the solenoid last week, new ATF-4 and a fresh filter. Ran perfect for about a week. Halfway to work I get the check engine light..and then it felt as if it was taking off in 2nd gear again.
If I put it in 1st..then it takes off in first, and I can shift it manually just fine.

Throwing p1757 again.

Any thoughts?
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-25-2013, 07:31 AM   #7
vadslram
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2006
Location: VA Beach
Posts: 4,808
At least on my 47 that code means your solenoid is showing over pressure.
They are pretty finnicky. Since you already replaced the parts and it worked for a short time my bet would be there was some crud still floating around in there it could have gotten caught in the passage. Pull the pan and solenoids again and blast out the passages with either brake or carb cleaner then not too high pressure air. Let it disapate completely and reinstall being as carefull as possible with the cleanliness.
vadslram is offline   Reply With Quote Quick reply to this message
Unread 11-25-2013, 07:34 AM   #8
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
I will try and give that a shot this weekend or so.

This is my first Grand..and first experience with the 42re. Ive really been wanting to start building this thing..but this is making me doubt even buying the thing as its a DD rigiht now..and its giving me hell.

I pulled the battery cable before I came into work today..so ill hook that up when I leave..if that clears it for a temporary amount of time would you still drop the pan again or would you start looking elsewhere?
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-25-2013, 07:34 AM   #9
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
And by solenoids do you mean solenoid? lol.

Im hoping the ebay parts I ordered were actually genuine mopar like they stated.
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-25-2013, 09:46 AM   #10
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
No other thoughts?
I could just shift it manually..but that is somehwhat unpractical
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-25-2013, 04:53 PM   #11
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
TCM...?
Anyone?
DaveS01 is offline   Reply With Quote Quick reply to this message
Unread 11-26-2013, 05:10 PM   #12
DaveS01
Registered User
1991 YJ Wrangler 
 
Join Date: May 2012
Location: Fort Oglethorpe, Georgia
Posts: 339
Bump
DaveS01 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.