My mysterious ZJ - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > My mysterious ZJ

~Artec JK 1 TON SWAP~Engo winches available at www.rockridge4wd.com! Free shippMagnaflow SS Cat Back Exhaust System, Street, High Clearan

Reply
Unread 10-12-2013, 03:20 PM   #1
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
My mysterious ZJ

so heres the deal 1997 zj with the 5.2. On the coldest of the past few (about 45 - 50 f) days the truck has died right after start. this has been a recurring problem ive been chasing for about a year now. ive replaced the idle air control motor and the throttle position sensor and ive also done a thorough cleaning of the throttle body but the problem still persists and its driving me insane.

But it will run if i give it gas after turning it on and after driving it a little bit it will stay running if i don't hop of the gas in 1st gear. after running for a bit it will stay running but will remain finicky.

So if you guys have any leads for me to chase it would be greatly appreciated.

Thanks again
Joe

mnkjoe is offline   Reply With Quote
Unread 10-13-2013, 06:27 AM   #2
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,053
When's the last time it got a full tune-up?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 10-14-2013, 10:33 AM   #3
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
ive replaced the plus in the past 2 yrs its got a new filter. ive cleaned the throttle body out really well. what else am i missing that could do it some good?
mnkjoe is offline   Reply With Quote
Unread 10-14-2013, 10:36 AM   #4
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
Also it has had a new fuel pump in the last 1.5 years so its got a good filter to.
mnkjoe is offline   Reply With Quote
Unread 10-14-2013, 04:27 PM   #5
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,053
Quote:
Originally Posted by mnkjoe View Post
ive replaced the plus in the past 2 yrs its got a new filter. ive cleaned the throttle body out really well. what else am i missing that could do it some good?
Wires, cap and rotor? How many miles were driven in the time period on the plugs?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 10-14-2013, 04:42 PM   #6
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
havent done the wires or cap and rotor and maybe about 15 to 20 thousand
mnkjoe is offline   Reply With Quote
Unread 10-14-2013, 04:43 PM   #7
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,053
Due every 30K. FWIW.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 10-14-2013, 04:46 PM   #8
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
sounds like they're due. whats fwiw?
mnkjoe is offline   Reply With Quote
Unread 10-14-2013, 05:12 PM   #9
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,053
For What It's Worth.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 10-14-2013, 07:21 PM   #10
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
well i just finished it all up and it seems to idle a bit nicer but not a huge difference, time will tell. but the contacts on the inside of the cap were very corroded as was the rotor itself so those needed to be replaced regardless. so thanks for that heads up. but im not convinced this will fix my problem, got any other speculations of what it could be?
mnkjoe is offline   Reply With Quote
Unread 10-14-2013, 07:29 PM   #11
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,053
Did you replace the wires?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 10-14-2013, 08:18 PM   #12
mnkjoe
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Maplewood, MN
Posts: 23
i did indeed
mnkjoe is offline   Reply With Quote
Unread 10-15-2013, 12:15 PM   #13
pstewart
Registered User
 
Join Date: Jul 2013
Posts: 13
I had a little bit of the same issue with my wife's durango, it would start up and idle high then low then eventually stall out. However it showed a code for the crankshaft sensor. Thirty bucks for the sensor and it idles great. Good luck, maybe this helps.
pstewart is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.