My 1984 2.5 liter engine won't stay running - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > My 1984 2.5 liter engine won't stay running

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineYear End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!!

Reply
Unread 02-02-2009, 11:38 AM   #1
rifleman2008
Registered User
1984 XJ Cherokee 
 
Join Date: Feb 2009
Location: Entwistle
Posts: 4
My 1984 2.5 liter engine won't stay running

I recently bought a 1984 Jeep Wagoneer with a 2.5 liter. Now that I got it home it has developed an annoying problem. I can start it and idles fine until it reaches operating temperature then it quits like someone has shut the key off. It will still turn over after it quits but all it does is back fire. It has to completely cool down before it will start again. Here a list of the things I have replaced since it started quitting; New air and fuel filter, new PCV valve, new spark plugs, new distributor cap and rotor, new coil, and new ignition control module. I am replacing the fuel pump, the oxygen sensor, and a bunch of vacuum lines today. I have cleaned the carb and taken off the muffler and catalytic converter. I unhooked all of the sensors one at time to see if that was the problem. I am curious if I missed anything. Any one got any ideas?(besides parting it out) Please let me know

rifleman2008 is offline   Reply With Quote Quick reply to this message
Unread 02-03-2009, 05:30 PM   #2
rifleman2008
Registered User
1984 XJ Cherokee 
 
Join Date: Feb 2009
Location: Entwistle
Posts: 4
I have the new vacuum lines on and the new fuel pump installed and it still doesn't stay running after it warms up. Does anyone know what those relays are for that are beside the starter solenoid and in behind the battery? The one in behind the battery is all corroded inside but I don't even know what it does and I can't find it in the repair manual

Last edited by rifleman2008; 02-03-2009 at 05:31 PM.. Reason: misspelled a word
rifleman2008 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.