MJ loss of power - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 01-24-2011, 05:47 PM Thread Starter
Nick_Knipp
Registered User
1986 MJ Comanche 
 
Join Date: Oct 2010
Location: Warner Robins, Georgia
Posts: 1,982
MJ loss of power

sup yall, just drove to Atlanta and back today, it was scary as hell. ever since i started it this morning it doesnt seem to get going when i push the gas pedal hard(accelerating) but it does catch up real slow, takes about 2 mins to get up to 60 lol. i pulled over, pressed on the clutch and reved up the engine to its max and doesnt seem to have problems getting the high idle. however when I'm on I75 going up very slight hills (I HATE hills!) it bogs down alot and speed drops to like 45-50. the gas pedals floored in and I'm in 4th and 5th, and it still aint going. once i get over the hill i can speed up again to like 60-65. but it still bogs when i floor the gas.

when i just entered atlanta it was getting worse and i started to smell something burning.. i pulled over for gas as well, popped the hood and saw oil all over the head. the 2 lines going into the top of the head were loose. oil was leaking all over the concrete, but my oil dipstick doesnt show serious loss of oil. and i knew that wasnt good. so i got the tape and held them down real good. arrived at my friends and helped her out. when we were done my jeep had been sitting for a good hour. i started back up and it seems to be fine til i got back on the interstate heading out of atlanta, then it started doing the bogging thing all over again. when i pulled over for gas i tapped the gas tank real good and filled her up. got back on the highway and seems to get some improvement, going 55-60 up small hills.

I'm at loss, tomorrow I'm taking out the tank and cleaning it first thing. then put the gas in my other jeep for daily driving. what does it sound like to you? lines are okay and in right places. filter, fuel pump, fuel pump filter, all are brand new and I had a friend from the jeep club help me install them.


"Don't curse in your profile"
-The Moderators
'86 MJ XLS 4x4 2.8L 3spd longbed buckets
'12 MK Sport 2.4L AT rescue green
Nick_Knipp is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Loss of power in 5.7 Wombat 43 Engines & Drivetrain 19 07-28-2010 08:11 PM
What causes power loss? dogbluedrummer Tires & Wheels 4 12-12-2007 01:53 PM
More Power Loss Squandith Stereos, CB & Ham Radios & GPS & Electrical. 2 12-07-2005 01:08 PM
CJ-7 - Loss and Regain of Power Snickrz75 Engines & Drivetrain 1 08-15-2005 07:37 PM
Power loss SpikeSpeigel Engines & Drivetrain 3 09-06-2003 10:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome