MJ loss of power - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > MJ loss of power

ECGS Black Friday Sale!!6th Annual, Beat Your Wife to the Credit Card Sale!50 in light bar /A pillar mount less than 500 at JeepHut.c

Reply
Unread 01-24-2011, 06:47 PM   #1
Nick_Knipp
Registered User
1986 MJ Comanche 
 
Join Date: Oct 2010
Location: Warner Robins, Georgia, Georgia
Posts: 1,982
MJ loss of power

sup yall, just drove to Atlanta and back today, it was scary as hell. ever since i started it this morning it doesnt seem to get going when i push the gas pedal hard(accelerating) but it does catch up real slow, takes about 2 mins to get up to 60 lol. i pulled over, pressed on the clutch and reved up the engine to its max and doesnt seem to have problems getting the high idle. however when I'm on I75 going up very slight hills (I HATE hills!) it bogs down alot and speed drops to like 45-50. the gas pedals floored in and I'm in 4th and 5th, and it still aint going. once i get over the hill i can speed up again to like 60-65. but it still bogs when i floor the gas.

when i just entered atlanta it was getting worse and i started to smell something burning.. i pulled over for gas as well, popped the hood and saw oil all over the head. the 2 lines going into the top of the head were loose. oil was leaking all over the concrete, but my oil dipstick doesnt show serious loss of oil. and i knew that wasnt good. so i got the tape and held them down real good. arrived at my friends and helped her out. when we were done my jeep had been sitting for a good hour. i started back up and it seems to be fine til i got back on the interstate heading out of atlanta, then it started doing the bogging thing all over again. when i pulled over for gas i tapped the gas tank real good and filled her up. got back on the highway and seems to get some improvement, going 55-60 up small hills.

I'm at loss, tomorrow I'm taking out the tank and cleaning it first thing. then put the gas in my other jeep for daily driving. what does it sound like to you? lines are okay and in right places. filter, fuel pump, fuel pump filter, all are brand new and I had a friend from the jeep club help me install them.

__________________
"Don't curse in your profile"
-The Moderators
'86 MJ XLS 4x4 2.8L 3spd longbed buckets
'12 MK Sport 2.4L AT rescue green
Nick_Knipp is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.