Misfiring! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 05-02-2013, 11:03 AM Thread Starter
T_force29
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2013
Location: Fairfield
Posts: 22
Misfiring!

I washed my engine bay last night, and this morning my jeep is misfiring at first it was a real low idle then that fixed itself and now In park it idles at 1100 and that is when I heard the misfire. Any suggestions?

T_force29 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-02-2013, 07:57 PM
1987_yj
Registered User
1987 YJ Wrangler 
 
Join Date: Sep 2012
Posts: 154
Pull the distributor cap and dry it inside, or let it dry. Dry the connections on spark plug wires, and re seal them with a dielectric grease. See how that goes.
1987_yj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome