Misfire? Distributor cap broken electrode. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 01-14-2012, 06:16 PM Thread Starter
JohnnyCommando8
Registered User
1994 ZJ 
 
Join Date: Mar 2009
Location: Las Vegas
Posts: 52
Misfire? Distributor cap broken electrode.

Here's what I have and what I know. 98 ZJ 5.9 ltr, po300, po303,po304, po306 codes. Did an tune up with champion plugs, wires, cap and rotor. Cleared codes, went for a drive and almost the same codes came back. Checked the cap again and noticed this time that the coil electrode inside the cap( middle spring loaded part) had broke off, also found the old one from the previous cap in there. Changed the cap and rotor with a better one and guess what, same codes just going down the road a few blocks. Is it possible that the coil is sending to much power to the cap and burning up that center electrode? I do have spark at all plugs. Misfires when accelerating. Any help would much appreciated. Thanks

JohnnyCommando8 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-04-2013, 06:52 PM
WatchMeFly023
Registered User
 
Join Date: May 2013
Location: Searsport
Posts: 16
Having same issue ever figure it outj
WatchMeFly023 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome