maybe water pump - JeepForum.com

 
LinkBack Thread Tools
post #1 of 13 Old 11-30-2013, 06:23 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
maybe water pump

was wondering has any one had little heat when at idle to good heat on throttle rad is full i don't see any movement in rad when idleing but rev it it is moves just a little but not like i have seen before and just put new temp switch in and reads really high when running but rad is cold as can be any idea's


stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 11-30-2013, 06:25 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
1995 grand cherokee 4.0l and idles high like my old 89 f150 used to do if she got hot

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
post #3 of 13 Old 11-30-2013, 07:22 PM
BIGBADWOLF
Registered User
2004 WJ 
 
Join Date: Aug 2012
Location: Charlotte
Posts: 731
That is what it sounds like. Check water pump impeller
BIGBADWOLF is offline  
post #4 of 13 Old 12-01-2013, 09:35 AM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
trying thermostat i just had a dumb thought and hoping it is it it maybe stuck closed

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
post #5 of 13 Old 12-01-2013, 12:08 PM
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury
Posts: 65
Sounds like the thermostat. Flush out your heater core as well

Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline  
post #6 of 13 Old 12-01-2013, 01:21 PM
BIGBADWOLF
Registered User
2004 WJ 
 
Join Date: Aug 2012
Location: Charlotte
Posts: 731
heater should still work with a stuck thermostat
BIGBADWOLF is offline  
post #7 of 13 Old 12-02-2013, 06:43 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
well still didn't fix it looking like water pump aint pushing coolant very well just didn't want to do it but have too

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
post #8 of 13 Old 12-02-2013, 09:41 PM
BIGBADWOLF
Registered User
2004 WJ 
 
Join Date: Aug 2012
Location: Charlotte
Posts: 731
Quote:
Originally Posted by schatzzy View Post
well still didn't fix it looking like water pump aint pushing coolant very well just didn't want to do it but have too
Yup I would almost bet the impeller is broken or worn. Heater is not controlled by thermostat...water circulates through heater whether thermostat is open or closed. So if heater ain't putting out warm air and hoses are cold that is usually a bad water pump.
BIGBADWOLF is offline  
post #9 of 13 Old 12-02-2013, 11:12 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
i got more heat when on throttle than idle and when i pulled thermostat i notice that the thermostat has nothing to do with heat i used to different vehicles where the thermostat or does control that i using some of my knowledge but as i can see jeep is not normal lol its crazy stuff hoping heat pipe will unscrew when i get the new water pump

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
post #10 of 13 Old 12-03-2013, 07:11 AM
BIGBADWOLF
Registered User
2004 WJ 
 
Join Date: Aug 2012
Location: Charlotte
Posts: 731
Quote:
Originally Posted by schatzzy View Post
i got more heat when on throttle than idle

hoping heat pipe will unscrew when i get the new water pump
Sounds like a weak pump. Heater pipe usually comes off easy, a vice helps. Be sure to use thread sealant B/C the pipe has to be in the correct position so you may not get it all that tight. I like to use Permatex indian shellac. but that is just me. Also use sealant on the bolt that goes all the way through the block and into the water jacket.
BIGBADWOLF is offline  
post #11 of 13 Old 12-03-2013, 09:45 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
need a good cleaner i can add to antifreeze cos its cold here and run it for a bit cos i put new pump on it still running warm not over heating but warm enough i just wondering if anti freeze is not getting to the new temp switch i did get it a little cooler but not much so not sure whats going on

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
post #12 of 13 Old 12-04-2013, 01:40 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
here where it running at
Attached Images
 

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
post #13 of 13 Old 12-05-2013, 08:40 PM Thread Starter
schatzzy
Registered User
1995 FSJ Cherokee 
 
Join Date: Nov 2013
Location: saint marys
Posts: 14
any body with any idea's for this please

stuff breaks all the time just got to fix it and move on if you can't wrench it weld it
schatzzy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome