Low idle - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 10-26-2012, 01:34 PM Thread Starter
Registered User
1999 TJ Wrangler 
Join Date: Aug 2012
Location: Hartford
Posts: 190
Low idle

I'm having low idle problems. 4 cyl 5 speed, 102k miles 99 tj. Starting it usually sounded funny slow to me but my mechanic said its just a jeep. It snowed here got colder and I didn't drive it for a day. I can't keep it from stalling without giving gas. Any quick fixes/check outs I can do? If I could get out without it stalling I would check the vacuum lines. Maybe some oxygen sensor? I'm no professional or genius with this stuff but I'm capable. What do you think?

maestro89 is offline  
Sponsored Links
post #2 of 2 Old 10-27-2012, 12:00 PM
Registered User
Join Date: Oct 2012
Posts: 3
I am no mechanic but I went through something like this with my 99 wrangler. It started off feeling like it would stall when I was stopped and it got worst and worst. After the mechanics practically replacing everything fuel related. They found out it was the jeeps computer . If this is the case they sell refurbished ones on line for about $275.
shipface1999 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome